summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-07 05:02:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-07 05:02:02 +0100
commitbe3f92540290a8a6527f0b854a8f76a51df3e78b (patch)
treed0ff23dd4d71f48b08de9bb5ddfeb1293ce05367 /dev-python/ujson
parentdev-python/tox: Bump to 4.2.6 (diff)
downloadgentoo-be3f92540290a8a6527f0b854a8f76a51df3e78b.tar.gz
gentoo-be3f92540290a8a6527f0b854a8f76a51df3e78b.tar.bz2
gentoo-be3f92540290a8a6527f0b854a8f76a51df3e78b.zip
dev-python/ujson: Bump to 5.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ujson')
-rw-r--r--dev-python/ujson/Manifest1
-rw-r--r--dev-python/ujson/ujson-5.7.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/ujson/Manifest b/dev-python/ujson/Manifest
index 1e6928ca6ef7..645f4991c8be 100644
--- a/dev-python/ujson/Manifest
+++ b/dev-python/ujson/Manifest
@@ -1,2 +1,3 @@
DIST ujson-5.5.0.tar.gz 7140414 BLAKE2B cca99fbb8cec447500c0dec34a952c4474acd0149783c887ee713cee60859570e41c9e349d49ff7eeba645d0c04a7e368da2ec8c42b6f55f59e971f834449e3a SHA512 883c0bd8b933557fc98556af1679de6df0372ee83a5533d8ea3f994dc13cd9bcd3140e2532ea1ad24419dab9ffbb59027e00f0a5e7ca285bf68358205a07bcd5
DIST ujson-5.6.0.tar.gz 7151977 BLAKE2B 59c0b88bdc59791889971993135484ce99763ad4805b36db7a3abc5e950c9132b917e7fbfb09870af916f5939d10e23ab44137f416179f75a06f424cf4b1154d SHA512 996c9746e011f116fcab3e61345df27cb2c1251852f758eff1d3465e19df03deb1a037669aa6ee5aad2fc6c2cf76c22075ad6a73158ff4dc81357e59a4ee244a
+DIST ujson-5.7.0.tar.gz 7152625 BLAKE2B 363fd77be3e2f8fb42a70db744ab4da12c0c8383103983b3555cee237497837abfcef102b19a51c0fa118fedd7847c568607c058f1d2cea76858a6bd89a226da SHA512 e18a1608a7fe79030e3ff307c9e95a0e238cd5049ee791eddbc07efa55853475d053268b80a8765023639ae8ff39f82b4ae2c04e82fc7dc5f3192a5134ec0757
diff --git a/dev-python/ujson/ujson-5.7.0.ebuild b/dev-python/ujson/ujson-5.7.0.ebuild
new file mode 100644
index 000000000000..7c752cf6c7c8
--- /dev/null
+++ b/dev-python/ujson/ujson-5.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Ultra fast JSON encoder and decoder for Python"
+HOMEPAGE="
+ https://github.com/ultrajson/ultrajson/
+ https://pypi.org/project/ujson/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-libs/double-conversion:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export UJSON_BUILD_DC_INCLUDES="${EPREFIX}/usr/include/double-conversion"
+ export UJSON_BUILD_DC_LIBS="-ldouble-conversion"
+ export UJSON_BUILD_NO_STRIP=1
+}