summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-11 15:39:10 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-11 16:24:18 +0100
commit74e9538e58b839cea8407436d0e7404c2fc284bb (patch)
tree664e36db27a465036a1097bb03b1ae486ad987a3 /dev-python/unidecode
parentdev-python/sphinx-celery: Bump to 2.1.0 (diff)
downloadgentoo-74e9538e58b839cea8407436d0e7404c2fc284bb.tar.gz
gentoo-74e9538e58b839cea8407436d0e7404c2fc284bb.tar.bz2
gentoo-74e9538e58b839cea8407436d0e7404c2fc284bb.zip
dev-python/unidecode: Bump to 1.3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unidecode')
-rw-r--r--dev-python/unidecode/Manifest1
-rw-r--r--dev-python/unidecode/unidecode-1.3.8.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/unidecode/Manifest b/dev-python/unidecode/Manifest
index 17889076c29c..565622cddafb 100644
--- a/dev-python/unidecode/Manifest
+++ b/dev-python/unidecode/Manifest
@@ -1 +1,2 @@
DIST Unidecode-1.3.7.tar.gz 192647 BLAKE2B bb32b816b9bd3cd8e29c84297a5ff81d60c2865c4b1e7039435e9819c5cd46057f3853d3eaf128ab13444105f81c5451533eac3a38d6181157bc8a30c86234bf SHA512 b4f7c8b40e1c2d05aab4e53b54fd657a3db35ea5feba0f95551ba2ccfd7e5b0da034aec6de11c5e43f23c3a9609f5cbe8e458fe18539ffdf7ef79e039e1b390e
+DIST Unidecode-1.3.8.tar.gz 192701 BLAKE2B 622b61b89d83070101626775187a666b830399bc86c67367b0793b6626667dc8f4655372c7bc8b61f2433ac927ec7572e5beb104407784dd2f8e20ced9ecf981 SHA512 0c93647b05b3ce041ba0091705630a4d75dfc249b3aa57b1d8bd26d26f1a067af1d0103a0f57ee2ea07224797ce204562e08df92d0fe60e250a16614bf146ece
diff --git a/dev-python/unidecode/unidecode-1.3.8.ebuild b/dev-python/unidecode/unidecode-1.3.8.ebuild
new file mode 100644
index 000000000000..658a3b8a24ba
--- /dev/null
+++ b/dev-python/unidecode/unidecode-1.3.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module providing ASCII transliterations of Unicode text"
+HOMEPAGE="https://pypi.org/project/Unidecode/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+distutils_enable_tests unittest