summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-15 19:04:21 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-15 19:04:24 +0200
commitf47a46e8ba0bc6982eab353a5e69e8e143e7e2d7 (patch)
tree1161f020bb34fae7b95d831338ca9f6a1c9987d1 /dev-python/urllib3
parentp/f/prefix/standalone/profile.bashrc: remove Debian magic. (diff)
downloadgentoo-f47a46e8ba0bc6982eab353a5e69e8e143e7e2d7.tar.gz
gentoo-f47a46e8ba0bc6982eab353a5e69e8e143e7e2d7.tar.bz2
gentoo-f47a46e8ba0bc6982eab353a5e69e8e143e7e2d7.zip
dev-python/urllib3: Remove old
Bug: https://bugs.gentoo.org/799413 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/urllib3')
-rw-r--r--dev-python/urllib3/Manifest1
-rw-r--r--dev-python/urllib3/files/urllib3-1.26.4-test-ssltransport.patch31
-rw-r--r--dev-python/urllib3/urllib3-1.26.4.ebuild97
3 files changed, 0 insertions, 129 deletions
diff --git a/dev-python/urllib3/Manifest b/dev-python/urllib3/Manifest
index 5e3859c6a5d4..db0a91444981 100644
--- a/dev-python/urllib3/Manifest
+++ b/dev-python/urllib3/Manifest
@@ -1,3 +1,2 @@
-DIST urllib3-1.26.4.tar.gz 293008 BLAKE2B 6ca88861baa87814d3856cd0f1fa0a6cb9e11ee745c782b598c4f5fe74b195ba47e8430b993ed8a5fb269153d700e4a803cd2ebc177e20e3186b3b26612262c7 SHA512 daf2ba432f2e4edaa6aa8c6bdaaea21fcb77cc5fdfd991f89b1f753b4f9901faab04120841e9fa8d93e2bd3d72cbdb647f1492d882266b4e0281c725e8d55a7a
DIST urllib3-1.26.5.tar.gz 292865 BLAKE2B 0b22a485635f70f198c022c13d03af2b1a9b6907276e3bc3acaa2242e1c632447762f86e9588e735462e6479ff93a172f458691ea9bf28ceaebd5e1cfbc55501 SHA512 4a1899b223b00894d49f6dff5fc95d410e5b0ab28c11f7e3cd82d03e50438b0c5b0adf693a33fd80f1586312dc0012836713998674da15531bf82d52645881f6
DIST urllib3-1.26.6.tar.gz 289927 BLAKE2B 197b0df759b27fc4906c565426e9c7b533fad56f10695ab5ae6c6c4d05d5c889dba906be526d8b8f41405f29696046b7db6e2cbb2fa16843af80e072138cc35f SHA512 19eb4b88b7a575db717db420ff79b304769d9a6d2b576a236d69719101c4d52d6b0079bd049c885e630f0dfd60471f8bb33836847e0569652cddece910ec2979
diff --git a/dev-python/urllib3/files/urllib3-1.26.4-test-ssltransport.patch b/dev-python/urllib3/files/urllib3-1.26.4-test-ssltransport.patch
deleted file mode 100644
index 346574fec91f..000000000000
--- a/dev-python/urllib3/files/urllib3-1.26.4-test-ssltransport.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/test/test_ssltransport.py b/test/test_ssltransport.py
-index 72b06b006..98682bd43 100644
---- a/test/test_ssltransport.py
-+++ b/test/test_ssltransport.py
-@@ -246,6 +246,7 @@ def proxy_handler(listener):
- )
- self._read_write_loop(client_sock, upstream_sock)
- upstream_sock.close()
-+ client_sock.close()
-
- self._start_server(proxy_handler)
-
-@@ -274,6 +275,10 @@ def _read_write_loop(self, client_sock, server_sock, chunks=65536):
- if write_socket in writable:
- try:
- b = read_socket.recv(chunks)
-+ if len(b) == 0:
-+ # One of the sockets has EOFed, we return to close
-+ # both.
-+ return
- write_socket.send(b)
- except ssl.SSLEOFError:
- # It's possible, depending on shutdown order, that we'll
-@@ -322,6 +327,7 @@ def socket_handler(listener):
- request = consume_socket(ssock)
- validate_request(request)
- ssock.send(sample_response())
-+ sock.close()
-
- cls._start_server(socket_handler)
-
diff --git a/dev-python/urllib3/urllib3-1.26.4.ebuild b/dev-python/urllib3/urllib3-1.26.4.ebuild
deleted file mode 100644
index e0026885ab4d..000000000000
--- a/dev-python/urllib3/urllib3-1.26.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library with thread-safe connection pooling, file post, and more"
-HOMEPAGE="https://github.com/urllib3/urllib3"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="brotli test"
-RESTRICT="!test? ( test )"
-
-# dev-python/{pyopenssl,cryptography,idna,certifi} are optional runtime
-# dependencies. Do not add them to RDEPEND. They should be unnecessary with
-# modern versions of python (>= 3.2).
-RDEPEND="
- >=dev-python/PySocks-1.5.8[${PYTHON_USEDEP}]
- <dev-python/PySocks-2.0[${PYTHON_USEDEP}]
- brotli? ( dev-python/brotlicffi[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- $(python_gen_cond_dep "
- ${RDEPEND}
- dev-python/brotlicffi[\${PYTHON_USEDEP}]
- dev-python/mock[\${PYTHON_USEDEP}]
- dev-python/pytest[\${PYTHON_USEDEP}]
- dev-python/pytest-freezegun[\${PYTHON_USEDEP}]
- >=dev-python/trustme-0.5.3[\${PYTHON_USEDEP}]
- >=www-servers/tornado-4.2.1[\${PYTHON_USEDEP}]
- " python3_{6,7,8,9})
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-test-ssltransport.patch"
-)
-
-python_prepare_all() {
- # tests failing if 'localhost.' cannot be resolved
- sed -e 's:test_dotted_fqdn:_&:' \
- -i test/with_dummyserver/test_https.py || die
- sed -e 's:test_request_host_header_ignores_fqdn_dot:_&:' \
- -i test/with_dummyserver/test_socketlevel.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local -x CI=1
- # FIXME: get tornado ported
- [[ ${EPYTHON} == python3* ]] || continue
- # tests skipped for now
- [[ ${EPYTHON} == python3.10 ]] && continue
-
- local deselect=(
- # TODO?
- test/with_dummyserver/test_socketlevel.py::TestSocketClosing::test_timeout_errors_cause_retries
- )
- [[ "${EPYTHON}" == python3.10 ]] && deselect+=(
- # Fail because they rely on warnings and there are new deprecation warnings in 3.10
- test/with_dummyserver/test_https.py::TestHTTPS::test_verified
- test/with_dummyserver/test_https.py::TestHTTPS::test_verified_with_context
- test/with_dummyserver/test_https.py::TestHTTPS::test_context_combines_with_ca_certs
- test/with_dummyserver/test_https.py::TestHTTPS::test_ca_dir_verified
- test/with_dummyserver/test_https.py::TestHTTPS::test_ssl_correct_system_time
- test/with_dummyserver/test_https.py::TestHTTPS::test_ssl_wrong_system_time
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_verified
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_verified_with_context
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_context_combines_with_ca_certs
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_ca_dir_verified
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_ssl_correct_system_time
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_ssl_wrong_system_time
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_default_tls_version_deprecations
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_no_tls_version_deprecation_with_ssl_version
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_2::test_no_tls_version_deprecation_with_ssl_context
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_verified
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_verified_with_context
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_context_combines_with_ca_certs
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_ca_dir_verified
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_ssl_correct_system_time
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_ssl_wrong_system_time
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_default_tls_version_deprecations
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_no_tls_version_deprecation_with_ssl_version
- test/with_dummyserver/test_https.py::TestHTTPS_TLSv1_3::test_no_tls_version_deprecation_with_ssl_context
- )
-
- epytest ${deselect[@]/#/--deselect }
-}