summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/utidylib/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/utidylib/files')
-rw-r--r--dev-python/utidylib/files/utidylib-0.2-fix_tests.patch48
-rw-r--r--dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch11
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
new file mode 100644
index 000000000000..b55a15119ba4
--- /dev/null
+++ b/dev-python/utidylib/files/utidylib-0.2-fix_tests.patch
@@ -0,0 +1,48 @@
+diff -uNr uTidylib-0.2.orig/tidy/test_tidy.py uTidylib-0.2/tidy/test_tidy.py
+--- uTidylib-0.2.orig/tidy/test_tidy.py 2004-02-24 08:53:52.000000000 +0000
++++ uTidylib-0.2/tidy/test_tidy.py 2009-07-25 15:50:56.000000000 +0000
+@@ -4,6 +4,10 @@
+
+ class TidyTestCase(unittest.TestCase):
+ def __init__(self, *args, **kwargs):
++ super(unittest.TestCase, self).__init__(*args, **kwargs)
++ self._shared = False
++ self._parents = []
++
+ foo = u'''<html>
+ <h1>woot</h1>
+ <hr>
+@@ -13,13 +17,13 @@
+ </body>
+ </html>
+ '''.encode('utf8')
+- file('foo.htm', 'w').write(foo)
++ file('foo.htm', 'w').write(foo)
+ self.input1 = "<html><script>1>2</script>"
+ self.input2 = "<html>\n" + "<p>asdkfjhasldkfjhsldjas\n" * 100
+ def defaultDocs(self):
+ doc1 = tidy.parseString(self.input1)
+ doc2 = tidy.parseString(self.input2)
+- doc3 = tidy.parse("foo.htm")
++ doc3 = tidy.parse("../foo.htm")
+ doc4 = tidy.parse("bar.htm") # doesn't exist
+ return (doc1, doc2, doc3, doc4)
+ def test_badOptions(self):
+@@ -33,7 +37,7 @@
+ self.fail("Invalid option %s should have raised an error" %
+ repr(dct))
+ def test_encodings(self):
+- foo = file('foo.htm').read().decode('utf8').encode('ascii',
++ foo = file('../foo.htm').read().decode('utf8').encode('ascii',
+ 'xmlcharrefreplace')
+ doc1u = tidy.parseString(foo, input_encoding='ascii',
+ output_encoding='latin1')
+@@ -58,7 +62,7 @@
+ ## self.failIf(len(doc2.errors)>1) # FIXME - tidylib doesn't
+ ## # support this?
+ self.failUnless(str(doc2).find('\n')<0)
+- doc3 = tidy.parse('foo.htm', char_encoding='utf8',
++ doc3 = tidy.parse('../foo.htm', char_encoding='utf8',
+ alt_text='foo')
+ self.failUnless(str(doc3).find('alt="foo"')>=0)
+ self.failUnless(str(doc3).find('\xc3\xa9')>=0)
diff --git a/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch b/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch
new file mode 100644
index 000000000000..761c4947dfa8
--- /dev/null
+++ b/dev-python/utidylib/files/utidylib-0.2-no-docs-in-site-packages.patch
@@ -0,0 +1,11 @@
+--- uTidylib-0.2-orig/setup.py 2005-12-01 00:48:14.000000000 +0100
++++ uTidylib-0.2/setup.py 2005-12-01 01:10:33.000000000 +0100
+@@ -54,7 +54,7 @@
+
+
+ setup_data = dict(packages=['tidy', ],
+- data_files=data_files,
++# data_files=data_files,
+ cmdclass=dict(install_data=install_data_utidylib,
+ bdist_wininst=bdist_wininst_utidylib,
+ install=install_utidylib,