summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-05 04:33:06 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-05 04:33:06 +0100
commitfc55b97d7b33831a2a97efb7ea9b5961f443ef48 (patch)
tree84d0a499cbb3a9280558fb7d79ce0c097ba941f7 /dev-python/waitress
parentdev-python/moto: Bump to 5.0.1 (diff)
downloadgentoo-fc55b97d7b33831a2a97efb7ea9b5961f443ef48.tar.gz
gentoo-fc55b97d7b33831a2a97efb7ea9b5961f443ef48.tar.bz2
gentoo-fc55b97d7b33831a2a97efb7ea9b5961f443ef48.zip
dev-python/waitress: Bump to 3.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/waitress')
-rw-r--r--dev-python/waitress/Manifest1
-rw-r--r--dev-python/waitress/waitress-3.0.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/waitress/Manifest b/dev-python/waitress/Manifest
index b0f2255a11fb..67cb11d0d7f7 100644
--- a/dev-python/waitress/Manifest
+++ b/dev-python/waitress/Manifest
@@ -1 +1,2 @@
DIST waitress-2.1.2.tar.gz 179823 BLAKE2B 0cbd172050f1da845c47b3a084cd5d7558c736c416372f22af4d4b6870ef6cd9050f4779fabaa5069b6b4783d748df98e2484eaed09da4d2cfc2d239ce15a05a SHA512 4ef487e116b34eede0f04a02ca7a78116a91664814067a8562d1cd15a4ab702e5faf4be7c122478324d017b6bb1f5315633b74405d00e900b34cc8f1a068da59
+DIST waitress-3.0.0.tar.gz 179393 BLAKE2B 266130e3f0610098c29fe11076f58c8f938439c9b80e9630b917e829b64c88d06803c9208137b220827ed1deb8e9ba2c396dfcaf8d92435ee738d580dbda6f26 SHA512 8b391eb194fce32fd78c1a20cd1afe8caf20e7e0c622e4be2b1ec7d3831cb5a607cda0637d08dcd3a55f2e8c84817abdad4636bf2ca260b12a774dcfa68b9176
diff --git a/dev-python/waitress/waitress-3.0.0.ebuild b/dev-python/waitress/waitress-3.0.0.ebuild
new file mode 100644
index 000000000000..3e14cb3ee147
--- /dev/null
+++ b/dev-python/waitress/waitress-3.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure-Python WSGI server"
+HOMEPAGE="
+ https://docs.pylonsproject.org/projects/waitress/en/latest/
+ https://pypi.org/project/waitress/
+ https://github.com/Pylons/waitress/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails on some systems, https://bugs.gentoo.org/782031
+ tests/test_wasyncore.py::DispatcherWithSendTests::test_send
+)
+
+src_prepare() {
+ sed -i -e 's:--cov::' setup.cfg || die
+ distutils-r1_src_prepare
+}