summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-22 06:37:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-22 07:33:07 +0200
commita3aa848634e232c92fa7b68af641a8fc656fc029 (patch)
tree0c9b54b65cc4ede3164f0e25a47f66942f847ef6 /dev-python/weasyprint
parentdev-python/sqlglot: Bump to 25.3.0 (diff)
downloadgentoo-a3aa848634e232c92fa7b68af641a8fc656fc029.tar.gz
gentoo-a3aa848634e232c92fa7b68af641a8fc656fc029.tar.bz2
gentoo-a3aa848634e232c92fa7b68af641a8fc656fc029.zip
dev-python/weasyprint: Bump to 62.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-62.3.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index d026c45d891e..90cd25486d32 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,2 +1,3 @@
DIST weasyprint-62.1.tar.gz 475687 BLAKE2B 80e5f24c2a52f60baada23239427cc80f34d9885d7decca172dcb420bcb76cdc49a4d15e21d4328e86bf9c7f9228f9a01da1244eba21f35a90f80a8e358b74bc SHA512 8eaee6daa610accd7594141102aecaf1b5debecbae196c442c32d522d4dcb54c411a215b77956b6e66deeb0abda66cb36d0e081d5d3fd69a8bf5a82716209aeb
DIST weasyprint-62.2.tar.gz 477895 BLAKE2B 918852d2eb9fd1b1e29101927e6251d827dbb7add8efa448dd7888c42bbe4079a514ff6d3d764ebb0cd96c0a1890f343b72575b1cc4e86959293a95054766d69 SHA512 d5254a39f6b5554e83fb2f8b88077a36d6f5a44f6d731b5f07c952429994f32a79c4d6c1187ed8ea9bdccada320c4347693bd4a21c61c6ad76f866161adfea81
+DIST weasyprint-62.3.tar.gz 477181 BLAKE2B 144b531e36c0e66fb715d2b1db20affb489e90dc7545435e2d2d5e5e89a0b77e03b5f08166a5ac6f488ed5e2ff5d268408d94edaf66a3327895f719e9329ff60 SHA512 c563019aac075d0f55a153483719a5ea1dd4dced8bf281aeb1c5ccb65b8591e883ea09ca86757073b10a4dd9dc2d718df83ff5913cd5b9ed703fb5cf71bf7fbf
diff --git a/dev-python/weasyprint/weasyprint-62.3.ebuild b/dev-python/weasyprint/weasyprint-62.3.ebuild
new file mode 100644
index 000000000000..ede5b4b196eb
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-62.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.3.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}