summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-29 08:40:57 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-29 08:44:03 +0100
commita5a15421499ccf4d7d031be8e9ac5193c19364e8 (patch)
tree527d93874893cd18c3f700c356ec63e5daff8e49 /dev-python/websockets
parentdev-python/pyparted: Remove old (diff)
downloadgentoo-a5a15421499ccf4d7d031be8e9ac5193c19364e8.tar.gz
gentoo-a5a15421499ccf4d7d031be8e9ac5193c19364e8.tar.bz2
gentoo-a5a15421499ccf4d7d031be8e9ac5193c19364e8.zip
dev-python/websockets: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/websockets')
-rw-r--r--dev-python/websockets/Manifest1
-rw-r--r--dev-python/websockets/websockets-11.0.3-r2.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
index a0ae85f598a2..0583165f45d3 100644
--- a/dev-python/websockets/Manifest
+++ b/dev-python/websockets/Manifest
@@ -1,3 +1,2 @@
DIST websockets-11.0.3-python3.12.patch.xz 4328 BLAKE2B 6ef94255ef5d95de8015eca14a5110373ab9ffadf4d1c86a892da1aac46caa2755cafeb643a222000a03262c1b1b1aea58132daff36981c00dbb68ce05484058 SHA512 421a6fb5a2a801850ea1fbaf890c11eac0f55ad288185f16f4244f316132591bc5a814636141ba3ada67aeff340f41de61d06c8db87010c858c1b0b02fd9b5ab
-DIST websockets-11.0.3.gh.tar.gz 347652 BLAKE2B b7d796744cb4c7b944e98644dfb9c0e44ba465a6dba71b9e891604f3012b025557dbcd5b7eeae02e71c84350e05b334f99404ddfda814a8984b7a893d3f092f7 SHA512 37a84d7c57da7a3e48870abf992ba96ee454b342610d51c06f7dfc7ee082b7fb51304518c208379c3dbd039eafb1a85444c257fed20b4605a52dc8fc938a4cca
DIST websockets-12.0.gh.tar.gz 352120 BLAKE2B cab704e0ee44a7012ee58d515a5ea7380a97a3cbb8f55d105c00c8c2b9ed992b4c87435875474de32e5969fd92256bdec830db0571399a1d2e5fb719b23c2d83 SHA512 f17943d444ce275b709cf89453b2d2cce09f5af26f0460e226c2e24cfbb425c825963352e130dcd4201587606355375b525d8e5a02eccbffbb3985a108a3ed5e
diff --git a/dev-python/websockets/websockets-11.0.3-r2.ebuild b/dev-python/websockets/websockets-11.0.3-r2.ebuild
deleted file mode 100644
index 5d3277b5d891..000000000000
--- a/dev-python/websockets/websockets-11.0.3-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for building WebSocket servers and clients in Python"
-HOMEPAGE="
- https://websockets.readthedocs.io/
- https://github.com/python-websockets/websockets/
- https://pypi.org/project/websockets/
-"
-# tests are missing pypi sdist, as of 11.0
-SRC_URI="
- https://github.com/python-websockets/websockets/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
- https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${PN}-11.0.3-python3.12.patch.xz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+native-extensions"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${WORKDIR}"/${P}-python3.12.patch
-)
-
-python_compile() {
- if use native-extensions && [[ ${EPYTHON} != pypy3 ]] ; then
- local -x BUILD_EXTENSION=yes
- else
- local -x BUILD_EXTENSION=no
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # very fragile to speed
- tests/legacy/test_protocol.py::ServerTests::test_local_close_receive_close_frame_timeout
- # requires DNS access
- # https://bugs.gentoo.org/909567
- tests/legacy/test_client_server.py::ClientServerTests::test_explicit_host_port
- tests/legacy/test_client_server.py::SecureClientServerTests::test_explicit_host_port
- )
-
- epytest tests
-}