summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-24 14:19:34 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-24 14:19:34 -0400
commite8e14b564d7f9cc694a1a96031703be15b2d41bc (patch)
tree4346b4dd46312051e1ac8686b1fd02abc171ab78 /dev-python/wxpython/wxpython-4.0.6.ebuild
parentllvm.eclass: Update @SUPPORTED_EAPIS (diff)
downloadgentoo-e8e14b564d7f9cc694a1a96031703be15b2d41bc.tar.gz
gentoo-e8e14b564d7f9cc694a1a96031703be15b2d41bc.tar.bz2
gentoo-e8e14b564d7f9cc694a1a96031703be15b2d41bc.zip
dev-python/wxpython: bump to 4.0.6
Also, take over maintainership. Closes: https://bugs.gentoo.org/632602 Closes: https://bugs.gentoo.org/667318 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-python/wxpython/wxpython-4.0.6.ebuild')
-rw-r--r--dev-python/wxpython/wxpython-4.0.6.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/wxpython/wxpython-4.0.6.ebuild b/dev-python/wxpython/wxpython-4.0.6.ebuild
new file mode 100644
index 000000000000..04e6a637c7d4
--- /dev/null
+++ b/dev-python/wxpython/wxpython-4.0.6.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# wxPython 4 supports python 2.7, but because it's going EOL soon and to ease
+# transition from wxPython 3.x, we make this package py3-only.
+PYTHON_COMPAT=( python3_{5,6,7} )
+WX_GTK_VER="3.0-gtk3"
+
+inherit distutils-r1 multiprocessing virtualx wxwidgets
+
+MY_PN="wxPython"
+
+DESCRIPTION="A blending of the wxWindows C++ class library with Python"
+HOMEPAGE="http://www.wxpython.org/"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="wxWinLL-3"
+SLOT="4.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="test webkit"
+
+# wxPython doesn't seem to be able to optionally disable features. webkit is
+# optionally patched out because it's so huge, but other elements are not,
+# which makes us have to require all features from wxGTK
+RDEPEND="
+ >=x11-libs/wxGTK-3.0.4-r301:${WX_GTK_VER}=[gstreamer,libnotify,opengl,sdl,tiff,webkit?,X]
+ media-libs/libpng:0=
+ media-libs/tiff:0
+ virtual/jpeg:0"
+
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ test? (
+ ${VIRTUALX_DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.0.6-skip-broken-tests.patch"
+)
+
+python_prepare_all() {
+ if ! use webkit; then
+ eapply "${FILESDIR}/${PN}-4.0.6-no-webkit.patch"
+ rm unittests/test_webview.py || die
+ fi
+ # Most of these tests disabled below fail because of the virtx/portage
+ # environment, but some fail for unknown reasons.
+ rm unittests/test_uiaction.py \
+ unittests/test_notifmsg.py \
+ unittests/test_mousemanager.py \
+ unittests/test_display.py \
+ unittests/test_pi_import.py \
+ unittests/test_lib_agw_thumbnailctrl.py \
+ unittests/test_sound.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ setup-wxwidgets
+}
+
+python_compile() {
+ DOXYGEN=/usr/bin/doxygen ${PYTHON} build.py dox etg --nodoc || die
+ ${PYTHON} build.py build_py \
+ --use_syswx \
+ --no_magic \
+ --jobs=$(makeopts_jobs) \
+ --release || die
+}
+
+python_install() {
+ distutils-r1_python_install --skip-build
+}
+
+python_test() {
+ virtx pytest -vv unittests || die "Test failed with ${EPYTHON}"
+}