summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-27 13:35:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-27 13:36:10 +0200
commit516649c5b6f547bff9a1c124eef1f1738042a233 (patch)
tree2248bf4fa2949bdc3e8b3f197d2cf21d86ca3315 /dev-python/xarray
parentdev-python/pytest-testinfra: Remove old (diff)
downloadgentoo-516649c5b6f547bff9a1c124eef1f1738042a233.tar.gz
gentoo-516649c5b6f547bff9a1c124eef1f1738042a233.tar.bz2
gentoo-516649c5b6f547bff9a1c124eef1f1738042a233.zip
dev-python/xarray: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.4.2.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 6be7f5e13390..6512b8974a11 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,3 +1,2 @@
-DIST xarray-2023.4.2.tar.gz 3692437 BLAKE2B d4fb5b184386bb7e9574ea3bdf484c3df82b9dca1fcd2380ac65b6a58da9f89da057d70efa9bd045b5cf6900c38f6aa4176fd2990cfe1369f987c452711307d6 SHA512 581b06a677b80c0f7e494a80ae52d75bd62bf613b13b7b7215458ceef727fb55a898c8da8cc6f8a6875ef6898007897eea8be55fb138f1dacad42965bbf1d956
DIST xarray-2023.5.0.tar.gz 3707468 BLAKE2B 55ee416c41aff8edcb609adcac1c0a2e1d4ae896c25ae3d771d755930725f69f854feac42c42558db598acc5d0a852370198908d85d5af9664c485052948f4ca SHA512 ab6538b280f05acc296d8d73003e07f494d330a2a6a486d2f3dac121aee9682e2fa46c05be868b23a31584c908e0f6454757bdac7ec032d3a6f79a4500c0629f
DIST xarray-2023.6.0.tar.gz 3711562 BLAKE2B 3b6b20cf0046aaeeafe87980c6c107486d79afd2881c4f98b42c17025f0d448763d37b5d5fd71cf17fcfcfbdc2d3337e985c7517038547300f4cf57ffe1aea98 SHA512 2b1b48bd90935a3b56f5f017085d40cc10081efbe0a84c908d1203066f29b4bf16fc89e771d961f26009bb20a84a59f4b9d99e42b5e25b2bbd8eca55a80839d6
diff --git a/dev-python/xarray/xarray-2023.4.2.ebuild b/dev-python/xarray/xarray-2023.4.2.ebuild
deleted file mode 100644
index a51fdf4d2c21..000000000000
--- a/dev-python/xarray/xarray-2023.4.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 multiprocessing pypi
-
-DESCRIPTION="N-D labeled arrays and datasets in Python"
-HOMEPAGE="
- https://xarray.pydata.org/
- https://github.com/pydata/xarray/
- https://pypi.org/project/xarray/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
- >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
- >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
-"
-# note: most of the test dependencies are optional
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/bottleneck[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/toolz[${PYTHON_USEDEP}]
- !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # warning-targeted tests are fragile and not important to end users
- xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
- # TODO: segv in netcdf4-python
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
- 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
- xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
-)
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p xdist.plugin -n "$(makeopts_jobs)"
-}