summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-25 13:21:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-25 13:21:28 +0200
commitb4d6fb112b9858b400f4633ad09ea353c41871e5 (patch)
tree1c024055e4652ca8f7aef661a4f09adfc41f9e03 /dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild
parentdev-python/elementpath: Bump to 2.0.1 (diff)
downloadgentoo-b4d6fb112b9858b400f4633ad09ea353c41871e5.tar.gz
gentoo-b4d6fb112b9858b400f4633ad09ea353c41871e5.tar.bz2
gentoo-b4d6fb112b9858b400f4633ad09ea353c41871e5.zip
dev-python/xmlschema: Loosen elementpath dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild b/dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..12fb0529cc95
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.2.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.0.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}