summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-03-27 17:22:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-04-05 15:32:43 +0300
commita14d2ec73a862613da84bda0853d8b474cca7609 (patch)
tree8f1cd9e13ea0cf95f47eeb9e6f3c4210b8175b3e /dev-python/yara-python
parentdev-python/yara-python: add 4.3.0 (diff)
downloadgentoo-a14d2ec73a862613da84bda0853d8b474cca7609.tar.gz
gentoo-a14d2ec73a862613da84bda0853d8b474cca7609.tar.bz2
gentoo-a14d2ec73a862613da84bda0853d8b474cca7609.zip
dev-python/yara-python: add 9999
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/30367 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/yara-python')
-rw-r--r--dev-python/yara-python/yara-python-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/yara-python/yara-python-9999.ebuild b/dev-python/yara-python/yara-python-9999.ebuild
new file mode 100644
index 000000000000..a4fa9fa8737f
--- /dev/null
+++ b/dev-python/yara-python/yara-python-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface for a malware identification and classification tool"
+HOMEPAGE="https://github.com/VirusTotal/yara-python"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara-python.git"
+else
+ SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =app-forensics/yara-$(ver_cut 1-2)*
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ cat >> setup.cfg <<-EOF
+ [build_ext]
+ dynamic_linking = True
+ EOF
+}
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}