summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-09 04:11:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-09 04:11:58 +0200
commit90036d85803963b50064420432048df47e91365d (patch)
tree8d4d982e44c36baaeb68a8f013308da10e60cd32 /dev-python/yarl
parentdev-python/yarl: Remove old (diff)
downloadgentoo-90036d85803963b50064420432048df47e91365d.tar.gz
gentoo-90036d85803963b50064420432048df47e91365d.tar.bz2
gentoo-90036d85803963b50064420432048df47e91365d.zip
dev-python/yarl: Bump to 1.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.11.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index fd6c605f4474..25f9b3a59e66 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1,3 +1,4 @@
DIST yarl-1.10.0.tar.gz 158919 BLAKE2B 07560c311c6388555fa10b94490576a0a5352be0ab511173624ca89322ad28281f7995593bc57c195a181dc4b80a5e3866b029294d9ce1d8ab0100036105636b SHA512 8854d04c5beb0cca37b32f0dec370ecf1309fc4f13f6c1c7da02bd9c49d9a8f95cb24218d3ba4e06bbf3d62226d69c87cf8ec8af71506a5680fb837dafba4d24
+DIST yarl-1.11.0.tar.gz 160812 BLAKE2B 166b919d866b2f224517a3b6ad728627aee2171b10f4b53e6a04ab2379cfcbe0105e5c1d4f43b5946b52164b5d8be6a6394a0468a6a9b06507603c4f65c5963b SHA512 826825786a6d8fd9de628fb89b053024e455a3c6fa8e56e059214b7bcdffc41451d8ac6b3d89fc123c3657287d3f8c3d475cb8ea733353bf9c2794b7e79b7bdf
DIST yarl-1.9.11.tar.gz 156445 BLAKE2B a5af473f7e66b1a4e9f97a4ff4e323764a05289e899926c803af16df985d47bdce7aa87d0099015c3a6033eb5cb942feab9879ea135076fdecdfc3d0afa98b94 SHA512 226a357f202693bece39136d595a444221fdde2727bc9d5fe392ccd80e86c6a35cee7d0882c66649b288efae5b3ae4ba1bcabb9844b8f47654c9ccbacc8337c0
DIST yarl-1.9.4.tar.gz 141869 BLAKE2B 367eac4674bf1190122f10bb1dc1c4f3d5e4263e1d95ff2b871067d55a894dc19a6bb5a6c673d1bed28b3c5f77c704799568edfe639d50f0ae10313eb847352d SHA512 e4f7917f1625b40125abae9a13d61795f97e8cf489735e15cf58476e97c3bcf840b1452482f1f7a737fbb2bdd1dc7bbcfa882d0a7f76a27dfb3aea72b7a66c82
diff --git a/dev-python/yarl/yarl-1.11.0.ebuild b/dev-python/yarl/yarl-1.11.0.ebuild
new file mode 100644
index 000000000000..1655b47881fa
--- /dev/null
+++ b/dev-python/yarl/yarl-1.11.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/expandvars[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}