summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 21:48:37 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-07 22:38:18 +0100
commit8e5e7973c2142c967f96dda919e57ff295bea999 (patch)
tree6d18043a30afc6cc234f0bdd8a655b939e3b7e09 /dev-python/ypy-websocket
parentdev-python/aiosqlite: new package, add 0.18.0 (diff)
downloadgentoo-8e5e7973c2142c967f96dda919e57ff295bea999.tar.gz
gentoo-8e5e7973c2142c967f96dda919e57ff295bea999.tar.bz2
gentoo-8e5e7973c2142c967f96dda919e57ff295bea999.zip
dev-python/ypy-websocket: new package, add 0.8.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/ypy-websocket')
-rw-r--r--dev-python/ypy-websocket/Manifest1
-rw-r--r--dev-python/ypy-websocket/metadata.xml13
-rw-r--r--dev-python/ypy-websocket/ypy-websocket-0.8.2.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/ypy-websocket/Manifest b/dev-python/ypy-websocket/Manifest
new file mode 100644
index 000000000000..f7f00009576a
--- /dev/null
+++ b/dev-python/ypy-websocket/Manifest
@@ -0,0 +1 @@
+DIST ypy-websocket-0.8.2.gh.tar.gz 13045 BLAKE2B 44cd1538247b68b54d161800f76f467f67d77d81726b4af01cbeeb045b77aeb7ec8fde7c126c5d54a0792be11bc97d41a624c99a80c2ea8178a358d045e59389 SHA512 6774d646a04afe4dcf72b6ec44bad5092ff40d8647c6650697340ebf6f2a548ba870ac2924de84626f10e88b6603a01c842e5a5d0ef71d3a75fc67a080ca22f6
diff --git a/dev-python/ypy-websocket/metadata.xml b/dev-python/ypy-websocket/metadata.xml
new file mode 100644
index 000000000000..9c277b18c8df
--- /dev/null
+++ b/dev-python/ypy-websocket/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">ypy-websocket</remote-id>
+ <remote-id type="github">y-crdt/ypy-websocket</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ypy-websocket/ypy-websocket-0.8.2.ebuild b/dev-python/ypy-websocket/ypy-websocket-0.8.2.ebuild
new file mode 100644
index 000000000000..7e47e92fcb06
--- /dev/null
+++ b/dev-python/ypy-websocket/ypy-websocket-0.8.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to y-crdt "
+HOMEPAGE="
+ https://pypi.org/project/ypy-websocket/
+ https://github.com/y-crdt/ypy-websocket
+"
+SRC_URI="https://github.com/y-crdt/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/aiofiles[${PYTHON_USEDEP}]
+ dev-python/aiosqlite[${PYTHON_USEDEP}]
+ dev-python/y-py[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Requires internet and nodejs
+ tests/test_ypy_yjs.py
+)
+
+distutils_enable_tests pytest