summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-30 03:48:27 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-30 04:24:05 +0200
commit258b81ace6e1245b329e6e963657afa37994cbed (patch)
tree2952041676f8dac98ce8815dd2616b213d0c9f81 /dev-python
parentdev-python/sqlalchemy: Bump to 1.4.53 (diff)
downloadgentoo-258b81ace6e1245b329e6e963657afa37994cbed.tar.gz
gentoo-258b81ace6e1245b329e6e963657afa37994cbed.tar.bz2
gentoo-258b81ace6e1245b329e6e963657afa37994cbed.zip
dev-python/Nuitka: Bump to 2.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.4.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 2fdd15af7305..7646e4e39f44 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,3 +1,4 @@
DIST Nuitka-2.4.1.tar.gz 3717378 BLAKE2B bcbfb41bd2fad4a72a7d6aa8122b28ab3f35cdb815f92a5cb9037443533f1689c1efdbb84feba7f63441fc86e9f4432fdff8167008d916fb18c8206dff5f7013 SHA512 48f8ae2701ccdf5353c4c15c1bbc99166427515a90518eb99d2063d39705d11ed37eaa4238a77054a42ee45a1408a39fb008b58ac9817821e2ec2c00f4cc7916
DIST Nuitka-2.4.2.tar.gz 3718310 BLAKE2B 266b26d8882f189ac5ec28a921a1ac8a30bc42d1ea870c3ebfba59c9c259ff246035143a13c204cb7ca4c59a457b1ece5e74bc3e7aab02546705d502cce35902 SHA512 23d2f8cea7765d8f6b5d785d2381d36c9f9b7a158d25680339f93667104af680ed0a186450c0697153e19b44e1dc77f338cb6f42db33fbc71815d675b0be75a8
+DIST Nuitka-2.4.4.tar.gz 3719076 BLAKE2B 513a84e9b8ec222f14df253eab53c82edf2a663e97ac4b272481f2c3df306ad4d9c7b7785295718c68aadb02b04c8a31b0dc58f9ed0418ad2e530dbcff1f1cbf SHA512 9cdcb377d3e7c0a64e7bb76fa3b1ca7ef6b1590c91bae82e34638fd2bab8e1497a6683c4db243e51e4653b105af43dd86e071c5c33c3baf15e58ee81e1388ca0
DIST Nuitka-2.4.tar.gz 3718936 BLAKE2B 385a2bb2bbaa971277d7812f53d5a141a9643b0886e46e90fc3f5f8e3cb991801414ce6215a075ffe7998a99a65d534d2af16f9c4adc6c48fd8dee428461563a SHA512 c622434f48bea3d651c4720f8d22f23ec1ba680f9b58c66772a229ca1dc671a6c702d34503d4f16588008300e8e7e32a73dd51b56da1de8edbb33fde62be6053
diff --git a/dev-python/Nuitka/Nuitka-2.4.4.ebuild b/dev-python/Nuitka/Nuitka-2.4.4.ebuild
new file mode 100644
index 000000000000..274aff9ae3b5
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.4.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}