summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-18 21:59:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-18 23:28:13 +0100
commit26165cb167fbdbd2a3c6c52821425d0e1dae81e3 (patch)
treeb6408a151941f63ce587b10beda2ba04f676217a /dev-python
parentdev-python/sentry-sdk: Bump to 1.5.8 (diff)
downloadgentoo-26165cb167fbdbd2a3c6c52821425d0e1dae81e3.tar.gz
gentoo-26165cb167fbdbd2a3c6c52821425d0e1dae81e3.tar.bz2
gentoo-26165cb167fbdbd2a3c6c52821425d0e1dae81e3.zip
dev-python/moto: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-3.1.1.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index b66ec5a48e0a..5988d0a09571 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -9,3 +9,4 @@ DIST moto-3.0.3.tar.gz 2071948 BLAKE2B 4b697e96c6e3db7b0582bda727b40cbaa9487b620
DIST moto-3.0.4.tar.gz 2204895 BLAKE2B 2b058b1b71fa2d74ca8b804f2bbc39a0f9505c8588ea602d73957ab3467b0ce7861078f479890a0668aa507be374af90fe8c2b48b9d64cdbcf26d4a9375f585a SHA512 71defd799c1ca14cfe2c119a309974a499aaf3c068bc88dfac535dde608c583a073a55d3a3d217f12ba086cc7366bf6bdf6c286493d81e74c65d673f600e4f49
DIST moto-3.0.5.tar.gz 2219507 BLAKE2B 019e0f66d8a183f9d758c372252488e79692e140db19820b568279148d88181b944f547d3a213072a29fb61115b73b40b656d3a0657078c54ca1c6de001c65ab SHA512 0529711897a25ff969bf945abfda9e86ab0a310b6b273240b35c981960e04ed14f879a4a86e2251f9824d1d5bc9241afe4a0b964981c8a02a176bca459025359
DIST moto-3.1.0.tar.gz 2231450 BLAKE2B 05a4b547b12d5a57b3d622918dc9d8d8f404a112ca1379b63c227386b6cdde3dcce0dfba6d831ff9c8c9e920f0bf7cada1218be537527a9aed19078985a31e82 SHA512 40d3bb242ac34575193a2087ec3ea29a3811cc71edd77de7bbc52872c6fc3e2acd816ebc99c4e0d2e5821916c2321c23ce98a8f71668bc8d82a733fb88e6270f
+DIST moto-3.1.1.tar.gz 2236948 BLAKE2B 8ab52a59dc09f4819c1169d26fd198b13159635c2571fd27e38eaedc0a83fa5e7af0a7adba90db1c48658a849ff0b17e8d9c9750a47c6981960ac786f3d9a4e0 SHA512 2354886a9b3b46bb33b832495a94f1dcd10cf5cb00454b6e8b6b6838618842ca06f8577c1826bca02a10e2f723cf474a7c492cd9fb587bdb660deb118c17aa4d
diff --git a/dev-python/moto/moto-3.1.1.ebuild b/dev-python/moto/moto-3.1.1.ebuild
new file mode 100644
index 000000000000..eeea7c760e83
--- /dev/null
+++ b/dev-python/moto/moto-3.1.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-python-0.93[${PYTHON_USEDEP}]
+ dev-python/boto[${PYTHON_USEDEP}]
+ dev-python/cfn-lint[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-py-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/pretty-yaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ tests/test_sqs/test_sqs_cloudformation.py::test_describe_stack_subresources
+ tests/test_swf/responses/test_decision_tasks.py::test_respond_decision_task_completed_with_schedule_activity_task_boto3
+ tests/test_swf/responses/test_timeouts.py::test_activity_task_heartbeat_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_decision_task_start_to_close_timeout_boto3
+ tests/test_swf/responses/test_timeouts.py::test_workflow_execution_start_to_close_timeout_boto3
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_sqs/test_integration.py::test_invoke_function_from_sqs_exception
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_exception
+ # broken by new expat
+ tests/test_sts/test_sts.py::test_assume_role_with_saml
+ tests/test_sts/test_sts.py::test_assume_role_with_saml_should_not_rely_on_attribute_order
+ tests/test_sts/test_sts.py::test_assume_role_with_saml_should_respect_xml_namespaces
+ tests/test_sts/test_sts.py::test_assume_role_with_saml_should_retrieve_attribute_value_from_text_when_xml_tag_contains_xmlns_attributes
+ tests/test_sts/test_sts.py::test_assume_role_with_saml_should_default_session_duration_to_3600_seconds_when_saml_attribute_not_provided
+ )
+
+ # pytest-django causes freezegun try to mangle stuff inside django
+ # which fails when django is not really used
+ epytest -p no:django -m 'not network'
+}