summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 09:37:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 10:40:26 +0100
commit370b1e5d073539f2a29a44edf2714929653e9c8a (patch)
treeb5a3971b374e4805f1139b7f26b2dc89ec0578e3 /dev-python
parentdev-python/phonenumbers: Bump to 8.12.37 (diff)
downloadgentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.tar.gz
gentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.tar.bz2
gentoo-370b1e5d073539f2a29a44edf2714929653e9c8a.zip
dev-python/xmlschema: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xmlschema/Manifest1
-rw-r--r--dev-python/xmlschema/xmlschema-1.8.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/xmlschema/Manifest b/dev-python/xmlschema/Manifest
index 21fa76f868b8..b2909297146b 100644
--- a/dev-python/xmlschema/Manifest
+++ b/dev-python/xmlschema/Manifest
@@ -1 +1,2 @@
DIST xmlschema-1.8.1.tar.gz 390835 BLAKE2B 5ba4e37bc52402a939e3c6508bb3d2cca33b85d73db9be375295de62587bae638d498435198a4b25bc6858bad19a89d14a11870774c631bcc9f1b22bb1c41f4c SHA512 741477d006270deb4a1d1b13bb404c6f4917047b0f68e85727a2dfe239a59f36f4160a6a88f26514a05865219a16ccbaa26bc319b06ac867aeabe008a778ddf8
+DIST xmlschema-1.8.2.tar.gz 392045 BLAKE2B 05b63c069bc6f7052e84f7af20b789e2e9b9e54eccbc28971006b924d1eff4b23a43e2a85356214603f4c2263f2478f7cc4321c4ae93e8106f31940098ab7ae2 SHA512 3a03206c732b3d46a58bcfdeafdccb08c7f3334c78df63901352d2d2eaebaabbb663d70329bd9667530a1e8c2bf1b7087eb493f971c3fa914d8944064e12361c
diff --git a/dev-python/xmlschema/xmlschema-1.8.2.ebuild b/dev-python/xmlschema/xmlschema-1.8.2.ebuild
new file mode 100644
index 000000000000..4860e6037578
--- /dev/null
+++ b/dev-python/xmlschema/xmlschema-1.8.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="An XML Schema validator and decoder"
+HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/elementpath-2.3.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" tests/test_all.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}