summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2021-06-15 01:42:46 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-06-15 03:56:15 +0200
commit4440598d01031e97414e0f107f3aa2b3a5b607e0 (patch)
treedb0faba46ccc1bf59ba9d2419adabd7934c26794 /dev-python
parentsys-cluster/ucx: drop -Werror (diff)
downloadgentoo-4440598d01031e97414e0f107f3aa2b3a5b607e0.tar.gz
gentoo-4440598d01031e97414e0f107f3aa2b3a5b607e0.tar.bz2
gentoo-4440598d01031e97414e0f107f3aa2b3a5b607e0.zip
dev-python/sip: move 5.5.0 to SLOT=5; add 6.1.0 (masked)
Drop the subslot because the sip module is no longer provided by this package starting from v5 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-5.5.0-r1.ebuild (renamed from dev-python/sip/sip-5.5.0.ebuild)4
-rw-r--r--dev-python/sip/sip-6.1.0.ebuild29
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 31dbfc2b6880..f28091691f4b 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,2 +1,3 @@
DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
DIST sip-5.5.0.tar.gz 1108126 BLAKE2B 59f0323b3befd7ebb89461e93e1e7e5707d11b2882bd524a45f3a6ba8d8a3c792aff5580027255812f6a3fa0854febeb418690fa6106efb21aab1610d66ef911 SHA512 0122beab575239cdb3b1430dc53a7f74175e3fbb3e113bcafced122ffbc4bd3d339b64a672ac1319ea14cd540b5877c2bcfeb7f8821fe8a3c8ba3ce9744bf803
+DIST sip-6.1.0.tar.gz 1441449 BLAKE2B 07740fd0c5feba2267d6af6acbd1f457b75f1e450558481a19cc3bbb8d9fc072335b61b9def236b2f3039ee5056a09694b5247fd49b5c006ea29029f08c31209 SHA512 6c1e6413020e8099ebf52b75dcb599c46d4e1d1ff8e8e672e76f77c1e421ae93dff66c9cd131b46642c567cfe876047eb9679d59babed11bf51e609b325b9e7c
diff --git a/dev-python/sip/sip-5.5.0.ebuild b/dev-python/sip/sip-5.5.0-r1.ebuild
index d7fd2fa0c238..26eee4168c33 100644
--- a/dev-python/sip/sip-5.5.0.ebuild
+++ b/dev-python/sip/sip-5.5.0-r1.ebuild
@@ -16,12 +16,12 @@ else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
fi
-# Sub-slot based on ${S}/sipbuild/module/source
-SLOT="0/12"
+SLOT="5"
LICENSE="|| ( GPL-2 GPL-3 SIP )"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
RDEPEND="
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
"
diff --git a/dev-python/sip/sip-6.1.0.ebuild b/dev-python/sip/sip-6.1.0.ebuild
new file mode 100644
index 000000000000..26eee4168c33
--- /dev/null
+++ b/dev-python/sip/sip-6.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+
+SLOT="5"
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc