summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 10:46:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 10:52:34 +0100
commit45875d97a93575b02dd1ff4ad47b548accd6efd9 (patch)
treec74745f2a170453729fa89b9064aa5605ee5fb42 /dev-python
parentdev-python/flask-security: Bump to 4.0.0 (diff)
downloadgentoo-45875d97a93575b02dd1ff4ad47b548accd6efd9.tar.gz
gentoo-45875d97a93575b02dd1ff4ad47b548accd6efd9.tar.bz2
gentoo-45875d97a93575b02dd1ff4ad47b548accd6efd9.zip
dev-python/pymdown-extensions: Bump to 8.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pymdown-extensions/Manifest1
-rw-r--r--dev-python/pymdown-extensions/pymdown-extensions-8.1.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pymdown-extensions/Manifest b/dev-python/pymdown-extensions/Manifest
index 715d3ad0bc4a..a5ec80e2f091 100644
--- a/dev-python/pymdown-extensions/Manifest
+++ b/dev-python/pymdown-extensions/Manifest
@@ -1 +1,2 @@
DIST pymdown-extensions-8.0.1.tar.gz 642787 BLAKE2B fe25fd828633bb1a653430431de9fd2f9abc881ff457d2c630befd7c094a147f4d4883088488a66c601190794c15fdfb8297a3252ba3b070412b2f18872f6126 SHA512 3f85bfe9128dcdc63cea4c2eb4d55173d697ae9d112559a74527ed64b3bd63f67eee119b81a54d0ac927bc21b6eb8411c03dc7afc77673739a81772c10ebe62a
+DIST pymdown-extensions-8.1.1.tar.gz 650451 BLAKE2B d72b4ff60747a5f2142b778d75ba438757f35e1bb45d1cf005c9ec7b187b8c6aa1e890ca1bf01b3a202dfd38c8f813c928041870a30bb2e0fc035e2a5ff9809e SHA512 a1472858b6afeb9b582cf97a4471e09e25dddcb0504d58f8aa703802fe0c075a0af2fa8e1895f02b48b5959297c37cd1feee789741d93a1739f9d19c3341b108
diff --git a/dev-python/pymdown-extensions/pymdown-extensions-8.1.1.ebuild b/dev-python/pymdown-extensions/pymdown-extensions-8.1.1.ebuild
new file mode 100644
index 000000000000..9261e00c48e1
--- /dev/null
+++ b/dev-python/pymdown-extensions/pymdown-extensions-8.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+ dev-python/mkdocs-material
+ dev-python/pymdown-lexers
+ dev-python/pyspelling
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Extensions for Python Markdown."
+HOMEPAGE="
+ https://github.com/facelessuser/pymdown-extensions
+ https://pypi.org/project/pymdown-extensions
+"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/markdown-3.2[${PYTHON_USEDEP}]"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}