summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-05 09:00:51 +0000
committerSam James <sam@gentoo.org>2023-01-05 09:01:34 +0000
commit4a8709aa2848af52736a61b804d0942c8cac904f (patch)
treeb96107dcffdfc2f980c6edfbd632607d68e3b176 /dev-python
parentsci-libs/proj: Stabilize 9.1.1-r1 amd64, #889810 (diff)
downloadgentoo-4a8709aa2848af52736a61b804d0942c8cac904f.tar.gz
gentoo-4a8709aa2848af52736a61b804d0942c8cac904f.tar.bz2
gentoo-4a8709aa2848af52736a61b804d0942c8cac904f.zip
dev-python/scipy: add USE=test-rust
pooch -> ... -> paramiko, which is masked on wd40 Bug: https://bugs.gentoo.org/889812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/scipy/scipy-1.10.0.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/scipy/scipy-1.10.0.ebuild b/dev-python/scipy/scipy-1.10.0.ebuild
index 797fb044c609..deff07afc050 100644
--- a/dev-python/scipy/scipy-1.10.0.ebuild
+++ b/dev-python/scipy/scipy-1.10.0.ebuild
@@ -44,7 +44,7 @@ fi
LICENSE="BSD LGPL-2"
SLOT="0"
-IUSE="doc +fortran"
+IUSE="doc +fortran test-rust"
# umfpack is technically optional but it's preferred to have it available.
DEPEND="
@@ -69,9 +69,11 @@ BDEPEND="
doc? ( app-arch/unzip )
fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? (
- dev-python/pooch[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
+ test-rust? (
+ dev-python/pooch[${PYTHON_USEDEP}]
+ )
"
EPYTEST_DESELECT=(
@@ -107,6 +109,12 @@ python_configure_all() {
python_test() {
cd "${T}" || die
+ if ! has_version -b "dev-python/pooch[${PYTHON_USEDEP}]" ; then
+ EPYTEST_IGNORE+=(
+ datasets/tests/test_data.py
+ )
+ fi
+
epytest -n "$(makeopts_jobs)" --pyargs scipy
}