summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-18 06:33:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-18 08:27:40 +0100
commit5b863d94ccd996fe5dde0d43ea6584865ad813af (patch)
tree090a67fb992a9a6202dc3ab28e7f710116eae623 /dev-python
parentdev-python/subprocess-tee: Bump to 0.4.1 (diff)
downloadgentoo-5b863d94ccd996fe5dde0d43ea6584865ad813af.tar.gz
gentoo-5b863d94ccd996fe5dde0d43ea6584865ad813af.tar.bz2
gentoo-5b863d94ccd996fe5dde0d43ea6584865ad813af.zip
dev-python/python-zeroconf: Bump to 0.44.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-zeroconf/Manifest1
-rw-r--r--dev-python/python-zeroconf/metadata.xml2
-rw-r--r--dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild59
3 files changed, 61 insertions, 1 deletions
diff --git a/dev-python/python-zeroconf/Manifest b/dev-python/python-zeroconf/Manifest
index 4b6449bf6dc0..765a02807d19 100644
--- a/dev-python/python-zeroconf/Manifest
+++ b/dev-python/python-zeroconf/Manifest
@@ -1 +1,2 @@
DIST python-zeroconf-0.39.4.gh.tar.gz 137174 BLAKE2B 9e7d66bec5ebb52754c5a45fd584229db2f20f37cc43830b31c903a6267aadc3a45a3f8c35fd329586aa81f083dc823f0e6d6fad3dc2b6cc5ada17a2eb4a2208 SHA512 0e69a31dd31111f95eda0a44ee7d00484d8b909448eef4ef41bef6e170a410ecdae02e01cc944ad7534634aa26ef0c95b465c784ee67de1c2cd0ec4ab040d445
+DIST python-zeroconf-0.44.0.gh.tar.gz 149523 BLAKE2B 544187ad7baff6ea7a13b3ee3a51e6c19d872f006df3727900cad588febab0b86218c31c689203d3b674eed8ca67f0c9b39f83efec255696fa8405a00551edc8 SHA512 4190ca1d892dcbe5e5020c15a18cf1db80e7623798b64ba45b18dbfb5dd624e7851026f99aec14547b037927c06b7d9186e44cb4790e47613cb16c0cde3c067d
diff --git a/dev-python/python-zeroconf/metadata.xml b/dev-python/python-zeroconf/metadata.xml
index c1970e1e2792..8b419fd2477f 100644
--- a/dev-python/python-zeroconf/metadata.xml
+++ b/dev-python/python-zeroconf/metadata.xml
@@ -8,6 +8,6 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">zeroconf</remote-id>
- <remote-id type="github">jstasiak/python-zeroconf</remote-id>
+ <remote-id type="github">python-zeroconf/python-zeroconf</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild b/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild
new file mode 100644
index 000000000000..071363ef01ef
--- /dev/null
+++ b/dev-python/python-zeroconf/python-zeroconf-0.44.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/python-zeroconf/python-zeroconf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}