summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <nils.freydank@posteo.de>2020-07-06 14:23:25 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-15 11:06:35 +0300
commit5c97273b0b8370a90241a2e98f4e5ec051fa98a6 (patch)
treea05d8577b95fcb2fbfd40190a5979e1e171c0929 /dev-python
parentapp-text/pytextile: Bump to 4.0.1 and support python3_9 (diff)
downloadgentoo-5c97273b0b8370a90241a2e98f4e5ec051fa98a6.tar.gz
gentoo-5c97273b0b8370a90241a2e98f4e5ec051fa98a6.tar.bz2
gentoo-5c97273b0b8370a90241a2e98f4e5ec051fa98a6.zip
dev-python/markups: Support python3_9 and add dep for highlighting
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markups/markups-3.0.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/markups/markups-3.0.0-r1.ebuild b/dev-python/markups/markups-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..18260f7687d2
--- /dev/null
+++ b/dev-python/markups/markups-3.0.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+
+DESCRIPTION="A wrapper around various text markups"
+HOMEPAGE="
+ https://pymarkups.readthedocs.io/en/latest/
+ https://github.com/retext-project/pymarkups
+ https://pypi.org/project/Markups/
+"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/python-markdown-math[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ app-text/pytextile[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+S="${WORKDIR}/${MY_P}"