summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-06 07:48:17 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-06 07:54:27 +0100
commit6760804e137e80e7cb19c2eccae0783a250c5b76 (patch)
tree850270c30dcb18167b76cc058e287ba16c0bcae9 /dev-python
parentdev-python/opentelemetry-sdk: Bump to 1.28.0 (diff)
downloadgentoo-6760804e137e80e7cb19c2eccae0783a250c5b76.tar.gz
gentoo-6760804e137e80e7cb19c2eccae0783a250c5b76.tar.bz2
gentoo-6760804e137e80e7cb19c2eccae0783a250c5b76.zip
dev-python/oslo-utils: Bump to 7.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-7.4.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 54efb3df4df9..5f6dd77490e5 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1 +1,2 @@
DIST oslo.utils-7.3.0.tar.gz 132561 BLAKE2B 98533d7b4e3111a548bfab4cb97854acb4485d84d89eed40fec713fcb14a63deedbf5c019f4ed44d9be535034f3323e96b9b9f5d30467899ea8cd1bdc217200b SHA512 71dcf6fe25cc4c0a2580c32b4a4ceaa22fa1046f84bebc2cbf2c3148379b569638c2e2cce3b7a9bb1bbb87660034baa199bd4a831baa4608ef2f4bbc1d39edb6
+DIST oslo.utils-7.4.0.tar.gz 135993 BLAKE2B 39e23fd850756ff4336d579ca9e3d1ca15de8370298b8bcba6adfc4dc4227c5e8d154347b5f8272ffe7b3f737317fae20f46fc6431cc5d1307b7b2a8d6d51f85 SHA512 b743778529c4da4889737aa249102dd6d7215ce7e794bfb8fb8a48fc448fe34d6a091a8afb551b46b53e2556015bf51ac75d12955a6582972bc7355b68a8799f
diff --git a/dev-python/oslo-utils/oslo-utils-7.4.0.ebuild b/dev-python/oslo-utils/oslo-utils-7.4.0.ebuild
new file mode 100644
index 000000000000..9a8e2700c1e1
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-7.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.utils/
+ https://github.com/openstack/oslo.utils/
+ https://pypi.org/project/oslo.utils/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.10.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/psutil-3.2.2[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.13[${PYTHON_USEDEP}]
+ dev-python/tzdata[${PYTHON_USEDEP}]
+"
+# qemu needed for qemu-img
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ app-emulation/qemu
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # require eventlet
+ rm oslo_utils/tests/test_eventletutils.py || die
+}