summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-05 20:10:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-05 20:30:25 +0100
commit7e011de67b85dfbb3d22da6253c964b9f06c7c9d (patch)
tree76dd803c760093357fb58e691af0994ff5bc4a0a /dev-python
parentkde-plasma/kwayland-integration: drop 5.27.11 (diff)
downloadgentoo-7e011de67b85dfbb3d22da6253c964b9f06c7c9d.tar.gz
gentoo-7e011de67b85dfbb3d22da6253c964b9f06c7c9d.tar.bz2
gentoo-7e011de67b85dfbb3d22da6253c964b9f06c7c9d.zip
dev-python/pysnmp: Bump to 7.1.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysnmp/Manifest1
-rw-r--r--dev-python/pysnmp/pysnmp-7.1.11.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pysnmp/Manifest b/dev-python/pysnmp/Manifest
index 7e80103a8f2f..7bad044e2ab1 100644
--- a/dev-python/pysnmp/Manifest
+++ b/dev-python/pysnmp/Manifest
@@ -1,4 +1,5 @@
DIST pysnmp-7.0.3.tar.gz 427830 BLAKE2B 5855095c40ca63bfb705293d33d061d94ad0958ab854863fb73468d6aee846ea2fd843f4444eb93a29cb8c1ec3043e1d90445628e66392b04d43d2c027c4ce79 SHA512 9c23ab7073b40ae43a6c56b81c05ef6639f99f44153dcb2f97a455402495cfb5dc8f70025331d5461e6e18a66e1de8246506947bc80465df67cba2381d0d891d
+DIST pysnmp-7.1.11.tar.gz 378381 BLAKE2B 4800f2d1542489c7700a1e6429d4ea5e1fca204e5a1af807182b536e8eed78225116daa70ee50f32aedce5063f1aa0cfceef1d6de173a06cb98446e7e684a0f8 SHA512 3cbc9731269db43abeb154a90c9a0146c07555e5adc0e40c07b254a0a4395f275d6e1093eb0a6edaa6787e70b4714f376ba28cd210a80db1014c6cb5aa5b2a74
DIST pysnmp-7.1.7.tar.gz 343907 BLAKE2B a7e03c9f973d30f911d7b6dea3d03221dfd7d2db67aeb97242de9ef6d6a85cedb5cdefedf55cf9bdd9f84812b65fc320c56fd027f2a613163ac54dd7bbf729e4 SHA512 f4b1da334427fee6d9fc9b069e0d03687f195237356ef5f7065690b68ca8fc8abc25969c32acfb8d156d70567fdcf63154eca1d066fadf8020cb4fc0bfb1ce6e
DIST pysnmp-7.1.8.tar.gz 344109 BLAKE2B 8c546eab5e0b937d3ef0259155cf6ee0afa6de00f05f6574a7e9f9207e97e204155eb310b81bae5badec20595c4b638189fd39e941ca141abc685f21b91b2bf0 SHA512 b300d9513021bb083ec0243449a39e635ff2bdbe8447d0cfb79fb1cfcea69e51ee593dadfca1f8a17590b648f86c63793757a56a9ba0aeab06a26c538499e50e
DIST pysnmp-7.1.9.tar.gz 376850 BLAKE2B 7ef76f636434b7dc5f2c3f3cb21f1071861f8d597dfd6a1e3b5672929645889641abe5e7797a4c8586ec0a702549fa9dc1c5a861a78eb5aada9be7411dbecab9 SHA512 034a99e96311b24e8e0bdfec85e1e0b3f31c9573ff34a131a1005812d762d7b886f4c20e3074551f50e5457fa0f9b2a5a03374df62d348ebdaa5a63851ac94da
diff --git a/dev-python/pysnmp/pysnmp-7.1.11.ebuild b/dev-python/pysnmp/pysnmp-7.1.11.ebuild
new file mode 100644
index 000000000000..8e1fe159f72f
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-7.1.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="
+ https://pypi.org/project/pysnmp/
+ https://github.com/lextudio/pysnmp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/cryptography-43.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pysmi-1.5.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO
+# distutils_enable_sphinx docs/source dev-python/furo dev-python/sphinx-copybutton dev-python/sphinx-sitemap
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/smi/manager/test_mib-tree-inspection.py::test_getNodeName_by_symbol_description_with_module_name_2
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ mibdump CISCO-ENHANCED-IPSEC-FLOW-MIB.py || die
+ mibdump LEXTUDIO-TEST-MIB || die
+ mibdump NET-SNMP-EXAMPLES-MIB || die
+ mibdump IF-MIB || die
+ epytest -p asyncio
+}