summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-08 17:03:41 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-08 17:03:41 +0100
commit8d7968744ae5f285da34af273e0f72db70ffdb87 (patch)
tree260154780450b3e5d441ae7803641ea0f6c6faee /dev-python
parentapp-misc/fastfetch: add 2.31.0 (diff)
downloadgentoo-8d7968744ae5f285da34af273e0f72db70ffdb87.tar.gz
gentoo-8d7968744ae5f285da34af273e0f72db70ffdb87.tar.bz2
gentoo-8d7968744ae5f285da34af273e0f72db70ffdb87.zip
dev-python/xarray: Gracefully deselect the test using seaborn
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xarray/xarray-2024.11.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2024.11.0.ebuild b/dev-python/xarray/xarray-2024.11.0.ebuild
index f8ef678508e4..68f19b04dd32 100644
--- a/dev-python/xarray/xarray-2024.11.0.ebuild
+++ b/dev-python/xarray/xarray-2024.11.0.ebuild
@@ -121,6 +121,12 @@ python_test() {
)
fi
+ if ! has_version "dev-python/seaborn[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ xarray/tests/test_plot.py::TestContour::test_colors
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}