summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-26 05:55:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-26 06:49:45 +0200
commita301ffb7ac7954aee438509c2306bfbff8f9dd32 (patch)
treeda3512dc8af25443249b64b43c914ecd5ab64e1f /dev-python
parentapp-admin/awscli: Bump to 1.34.27 (diff)
downloadgentoo-a301ffb7ac7954aee438509c2306bfbff8f9dd32.tar.gz
gentoo-a301ffb7ac7954aee438509c2306bfbff8f9dd32.tar.bz2
gentoo-a301ffb7ac7954aee438509c2306bfbff8f9dd32.zip
dev-python/starlette: Bump to 0.39.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/starlette/Manifest1
-rw-r--r--dev-python/starlette/starlette-0.39.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/starlette/Manifest b/dev-python/starlette/Manifest
index 4ccc16fbe7cd..20b728d3887f 100644
--- a/dev-python/starlette/Manifest
+++ b/dev-python/starlette/Manifest
@@ -3,3 +3,4 @@ DIST starlette-0.38.4.gh.tar.gz 2571795 BLAKE2B 0a4d9856b3bf51a2d86b36bec74df784
DIST starlette-0.38.5.gh.tar.gz 2569392 BLAKE2B 9ad32478b22cc743652eda43ad71e6b43af9a1c9b42614a16b5fbae282cfdf5e1c092717bb35711d256e75249cf8705d3545289236c78382673f87a9706b7599 SHA512 1ad5ddb497eb35c8b0b2569218b7e98cb4bee0fc2497912aa86bc75fd894264f8d30c886313cc4aa6dd02a24197d71dbd0640b7e2f0a472ce1002ee5cba5ae59
DIST starlette-0.38.6.gh.tar.gz 2569402 BLAKE2B 1d580aa6d5f9782a0f3688f3ebde59ca0a8ec8756b3c05c9d9465af0ead346a566b28e14d068392d6d16a55a22a0c77adc3c99f781003df0b5963cfbb0e01514 SHA512 eeaf3c573e587ce4eec8c10f879b20059e0ca4f14c04865a744a8aefe1b3f51327a291e36db312d119b9df51475584b20d8407332a8817eee5b387255d4826d6
DIST starlette-0.39.0.gh.tar.gz 2571995 BLAKE2B 8db760feac7b61bf7e438bff20f7eeb21b91c20fffb7b72c630bbf453d1e3f0e679d7a7726d1a1e7438586da63b950679781ca76abbdaf5d21489a4cc555c896 SHA512 f75cc19178b11a10d43e4b206ab89ca053907bfe5143f46d26c8d6b5e254263fe77a8ed760dfcb3e7f229fc3dc08df8f8bc914db454f012cda81edfb7d06613c
+DIST starlette-0.39.1.gh.tar.gz 2572649 BLAKE2B f8b1fb9c64ae73d6018e9ec2f069b413c14060a076d9b3cdcaa6a56219733b65e73a7b8ed8abc6caf4bb896e88a34e326fd98a6f2859e5c05a200bac94aa16bb SHA512 b019d368b5610d8b865a17ff98bec40dacaf1dc830150da907a01a900b058519a9170c80ed92a5a78c835c833e089234e38f939523923e3e566fb2d59de28bfe
diff --git a/dev-python/starlette/starlette-0.39.1.ebuild b/dev-python/starlette/starlette-0.39.1.ebuild
new file mode 100644
index 000000000000..366226d021e8
--- /dev/null
+++ b/dev-python/starlette/starlette-0.39.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="The little ASGI framework that shines"
+HOMEPAGE="
+ https://www.starlette.io/
+ https://github.com/encode/starlette/
+ https://pypi.org/project/starlette/
+"
+# no docs or tests in sdist, as of 0.27.0
+SRC_URI="
+ https://github.com/encode/starlette/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-5[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/python-multipart-0.0.7[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+: ${EPYTEST_TIMEOUT:-180}
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Unpackaged 'databases' dependency
+ tests/test_database.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p anyio
+}