summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-06 08:00:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-06 08:00:19 +0100
commitb8d0e46fdf268aa7375b4c9e31c32c076aced9b4 (patch)
tree8be8d096a902d9a19bbd0f60d9e6b95becb06fac /dev-python
parentdev-python/cmd2: Bump to 2.5.3 (diff)
downloadgentoo-b8d0e46fdf268aa7375b4c9e31c32c076aced9b4.tar.gz
gentoo-b8d0e46fdf268aa7375b4c9e31c32c076aced9b4.tar.bz2
gentoo-b8d0e46fdf268aa7375b4c9e31c32c076aced9b4.zip
dev-python/caldav: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 6e0ceb3cb393..b0d06d59e08e 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1 +1,2 @@
DIST caldav-1.3.9.tar.gz 106392 BLAKE2B 6b7ca6b7be72b604f54663c5d2a79bc0a3b9874c791407fb7161357bad4cc5016249d0dd8278fb394ff3ce9bfa681f8e034710706faf2d1b4eb8345ac3ba110c SHA512 d368511b82d341406801ecca6aa371a2b4f5641eedba784fa869d76ebd1836991fb2d1cdc12d42feb1a55db73dfb5d80da7efebf95759fd7b6e122129a001ae3
+DIST caldav-1.4.0.tar.gz 141012 BLAKE2B a7936779571c01935f827d2a1a6bd059354431735b316fdbcf324a8be7ccbf4f4aaa88fac902088b39cc96c7b2d7b85d6a8bf87e06f4d30c95dcd7135535537d SHA512 15684684080bb4de2eefc20babcd75ed2de753fad516f456f3ef93439ef94ed31afcce725cde09b722e52fb1af03631d1489151e31e1be5745dc210ee51dca0f
diff --git a/dev-python/caldav/caldav-1.4.0.ebuild b/dev-python/caldav/caldav-1.4.0.ebuild
new file mode 100644
index 000000000000..6029aa7c56c8
--- /dev/null
+++ b/dev-python/caldav/caldav-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/recurring-ical-events-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest