summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-07 08:27:02 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-07 13:49:11 +0200
commitbe6e69f8c513d22497461ab11e7b29f2e34c9a55 (patch)
treecebf5ec31908243e0f9e39e6b57b0de45745c872 /dev-python
parentmedia-sound/guitarix: use array to pass configure args (diff)
downloadgentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.tar.gz
gentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.tar.bz2
gentoo-be6e69f8c513d22497461ab11e7b29f2e34c9a55.zip
dev-python/tabulate: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tabulate/Manifest1
-rw-r--r--dev-python/tabulate/tabulate-0.8.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/tabulate/Manifest b/dev-python/tabulate/Manifest
index 929131811ac7..c3b9407e80e2 100644
--- a/dev-python/tabulate/Manifest
+++ b/dev-python/tabulate/Manifest
@@ -1 +1,2 @@
DIST tabulate-0.8.1.tar.gz 45666 BLAKE2B f46a0c8bed50e37a2d536d28fe822fb92fbc124c7ac4c29260b6a7ab9828588f49b7e94ec8925505ef9724b1fb4647e5e9207d29b2f3a2f526641ac7ac229ce0 SHA512 f724fbabee53c738c846a5cf645470f5f97074e2b33eb030b4859478931661dac53e5446d77a656553e2dec323230bb116d350997e1407d794382f537e6dfdf5
+DIST tabulate-0.8.3.tar.gz 46234 BLAKE2B 1310de381265bf150cdef72b653175b1ab95a8339bf1934cece830ce9e644ed9d3d441eb3c3721509368334d11160054aa4d75a17751e493c47dbeee22c466e2 SHA512 7f0205a4d80ed0b426a45622a3b8ec0a9b77cf6d67c1207db7fbc20a12e83a15748e63d5f8e5e65fa348b6265fd0cac93be4d04f9c1c182476b93507e1131cbf
diff --git a/dev-python/tabulate/tabulate-0.8.3.ebuild b/dev-python/tabulate/tabulate-0.8.3.ebuild
new file mode 100644
index 000000000000..47d173efc49a
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.8.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.org/project/tabulate/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+# TODO: optional test-dep on colorclass
+DEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_impl_dep 'sqlite')
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ esetup.py test
+}