summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-19 05:34:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-19 05:34:52 +0100
commitc90065ba12ded7ab4c2f3659ec41cbdff2a4f1e7 (patch)
treede6c204d661c200b5129d9a56f0d4e6230454e64 /dev-python
parentdev-python/libcst: Bump to 1.5.1 (diff)
downloadgentoo-c90065ba12ded7ab4c2f3659ec41cbdff2a4f1e7.tar.gz
gentoo-c90065ba12ded7ab4c2f3659ec41cbdff2a4f1e7.tar.bz2
gentoo-c90065ba12ded7ab4c2f3659ec41cbdff2a4f1e7.zip
dev-python/pytest-httpx: Bump to 0.34.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-httpx/Manifest1
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index b2af64a19f7d..afa405ce2d93 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1 +1,2 @@
DIST pytest_httpx-0.33.0.tar.gz 51708 BLAKE2B c4b4a5bc41c44b982dcfe81f09ec4b3ee1eeed9cdc52cea6889988692bfb312eb7c4105cdcd60fadbbf0602236e2e5baf3c1a448248189214c0ec77cde8a3ea4 SHA512 96e3b5e0264f61644ed22fc809f35d0b2b255aa2ba75a5bf33d165c35276f2b731689b70cfbab5b5c901b1be4ff59c4b21704f8b15453582a6095611380830c8
+DIST pytest_httpx-0.34.0.tar.gz 54108 BLAKE2B b2c761a993d5c15aa28ee4d2b29ed44764c9825a3b9a9a471eef534a4f040324d6c822bfd413090d86428591be60d9092541a77188d8ef84bd3e333a976647da SHA512 49ca01ddd16fb68213ec2178111c65fb3f47be6416b67ebe356a47f658140ee42e275e07e377c6740956d895a4b1a719c2cf12ad9cbabc339b20cca94b892ef0
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild
new file mode 100644
index 000000000000..609a6666899b
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.34.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest