summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-23 05:07:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-23 06:12:25 +0100
commite7ceb041768f90ea13cc07d5b924762bde2212e0 (patch)
treeae3d1d90fabbfc2b7c0f9518ffcb41ac68355225 /dev-python
parentsys-apps/flatpak: add 1.14.5, python3_12 (diff)
downloadgentoo-e7ceb041768f90ea13cc07d5b924762bde2212e0.tar.gz
gentoo-e7ceb041768f90ea13cc07d5b924762bde2212e0.tar.bz2
gentoo-e7ceb041768f90ea13cc07d5b924762bde2212e0.zip
dev-python/botocore: Bump to 1.34.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.7.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index ec850e22077c..add3ce718004 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -6,3 +6,4 @@ DIST botocore-1.34.3.gh.tar.gz 12574694 BLAKE2B f171337299c886d0b9c78e50ea57b0e2
DIST botocore-1.34.4.gh.tar.gz 12582501 BLAKE2B fa7578a30cf8e6c72ef83756923c77f4c8d89c6ce0902614f6661d6174b3d1fc176866087dea80b61c8328137796f41a1e295fc04de7fee34267b521cc3d9201 SHA512 07e60e42bfd2be4de0b2cf824978acd87eadeba77e8e191fb4e29001e9868494fe9e4676b38f6769557b0119139cb9f432d426cba34307504e8a218ccec66c0f
DIST botocore-1.34.5.gh.tar.gz 12587260 BLAKE2B 08ffafc5b6678cb48f7ca59413c787fcb15924076927113634e4db674d6cac52a1cae72f559abf614be622137e28b0862b140bd2e5c92231aa659d15d655fad9 SHA512 c99a9c4d1cc86bf6aab3c8672f2dc95f69577fdbfb5cc4723bc6be41df9a34aa07eae29ab00ec84b55e50694b1288ad8a5b5673f4d6839c13608f28f0c9420b0
DIST botocore-1.34.6.gh.tar.gz 12597372 BLAKE2B 34aaf3e27478440a4f8fac28adb0f6bd9e63851435fd1bd51699a8b0c2a384d8aace86c4629404cb30602606a5497d5b30628e7a2174095914ab34879c1c13de SHA512 c90de3f2c18610ee5d5e649d368eebdbdb97ec737637b06ef8d5951502f2b5655a72b4859025cb007213b665c075078cc604bd7ac95af4ccf8073800bf346d34
+DIST botocore-1.34.7.gh.tar.gz 12606475 BLAKE2B 387ee7dfab43c44c39c7b0566b6ddcb2b666024b5b7bee2c996194988781c169e1e9462b36d09861d1c3ca899d263392f3d79129e7a2f2fc4bbfed402f5c7dd6 SHA512 3f162d4d028dd81da552e0117671971aa891bf8fab513730f40083660fa83c1f82bf1b52875cf9f7f11089ecdd79f084f3c8e76227aa826c1aac7e5735032450
diff --git a/dev-python/botocore/botocore-1.34.7.ebuild b/dev-python/botocore/botocore-1.34.7.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}