summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-31 17:42:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-31 17:58:02 +0100
commitecd2181e4f31f3468edf2bb518a8aa9cb7b7e0d6 (patch)
tree23bc038845feb76be2ddace087e1acdefc9a853a /dev-python
parentdev-python/BitVector: EAPI 8, PEP517 (diff)
downloadgentoo-ecd2181e4f31f3468edf2bb518a8aa9cb7b7e0d6.tar.gz
gentoo-ecd2181e4f31f3468edf2bb518a8aa9cb7b7e0d6.tar.bz2
gentoo-ecd2181e4f31f3468edf2bb518a8aa9cb7b7e0d6.zip
dev-python/CppHeaderParser: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild
new file mode 100644
index 000000000000..3cf30d41e4ce
--- /dev/null
+++ b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parse C++ header files and generate a data structure"
+HOMEPAGE="
+ https://senexcanis.com/open-source/cppheaderparser/
+ https://pypi.org/project/CppHeaderParser/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"