summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-10 05:12:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-10 05:35:03 +0100
commitf20eee9847cd1fad368db28298d93bad524a2c20 (patch)
tree702299887e559ddf25f20ec2ac3dbcaffce52f66 /dev-python
parentdev-python/pytest-subtests: Bump to 0.14.1 (diff)
downloadgentoo-f20eee9847cd1fad368db28298d93bad524a2c20.tar.gz
gentoo-f20eee9847cd1fad368db28298d93bad524a2c20.tar.bz2
gentoo-f20eee9847cd1fad368db28298d93bad524a2c20.zip
dev-python/sqlglot: Bump to 25.34.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-25.34.1.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index e37a34acdbb4..722bd1ad7499 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -15,6 +15,7 @@ DIST pyo3-macros-backend-0.22.6.crate 66312 BLAKE2B ec0b11bee1ad2192e8d95cebab00
DIST quote-1.0.37.crate 28558 BLAKE2B a7d007a69e619f853af94333e1066bb767013312bd99f147b1b153611242bcfa9c76768b1ba47278589db309a9acd61a772c8ec3b567e48439bb9d831f9326d4 SHA512 c4ed21428c1f89cf22b85d80720a7869831a9c129d694617b0ce8c258278114ab98846f3f653abf736d1c86bc9224bbd695e9a7b06aa3adf292d02e1ef14cc05
DIST sqlglot-25.33.0.tar.gz 19759713 BLAKE2B 238af5c257d9eff2efb6c785134c3f3c42d31d1ec6c289e2bd7b2948ed898c2f44ecd7ce185042d006ce8032e6be75933bebef75741115365589a43e330c7a4b SHA512 e9d21abc3d05d69c6f4b25be83c996bad06115847ec389b76d036b8f1f81debf6c14cf2432019a91dfd87188ad03f457047f17ba1854278192980d565fe94b18
DIST sqlglot-25.34.0.tar.gz 19770469 BLAKE2B 764ef90d3b446c854e18a73a08559201a52a365f5565cd700ea1e9f006eab2ec50c0eacefb18c8221958ab6b8aa6f5174e78f3243a7817837af510e388b17fa1 SHA512 8c97ebcf0082dcd05ab588ec94e47cb324f670a02ad25db770637e76b412c1616dbf4298dd0923b4e237149ed6556a46859e64ca605fa566a9792ce1f7726ef0
+DIST sqlglot-25.34.1.tar.gz 19772522 BLAKE2B 70ec20f25436858df7ae116d7c5cb68439b28601384a94e82343d45d3a3ebdd5bf2cae7f1455f9bb37144923eaf0ca0d4d5aa8a4b28ff36c767c0a38a3443d56 SHA512 62580df95d3984c8967e0c883156ba6bb089ce2180b24cb09d53d2e84c5ed2462808f7ce6858e3a91243a7ce25f5157dca5a0efe161afab0ccdb1428d9b918bb
DIST syn-2.0.87.crate 278076 BLAKE2B 93385f64103fdb482bec34c7912474ae7a5935948715e6eb9a54907e0db5c39f089f6cd393bab33c935c59a1bbb0f4099431f206343811c1a450554d96a35756 SHA512 bcfff545d6dfefd81e09f8f30a86bdd85759b3a7d4093ef3365ed02718e10dbd604c52b94c9d7fa955d339fdc5b6c079940c6f345b5a48c52b5c8607794ca6f2
DIST target-lexicon-0.12.16.crate 26488 BLAKE2B e7950e4a302059a1bfc9bc15618a3c1b971a17cffae117a6e8f5f63a0d82fd2bd02680301d15338612d5426d349dd24cfee30ee787a15a7d3187f2a6825e69ce SHA512 092639957c4a0391560b6442b31c47159c04d12e971010f730a6ec9cb5389e4be903ef3d7daa06db95e64dc78b6970731fb647179ebaad2b12e9ed5e9b24da27
DIST unicode-ident-1.0.12.crate 42168 BLAKE2B 4cede03c08758ccd6bf53a0d0057d7542dfdd0c93d342e89f3b90460be85518a9fd24958d8b1da2b5a09b5ddbee8a4263982194158e171c2bba3e394d88d6dac SHA512 bc1824e1e4452a40732fc69874d7e1a66f7803717a314790dcf48867eba34bc9441331ef031e386912e52c385645c25b6ed39d4f149973b5b97371b1b96b1920
diff --git a/dev-python/sqlglot/sqlglot-25.34.1.ebuild b/dev-python/sqlglot/sqlglot-25.34.1.ebuild
new file mode 100644
index 000000000000..27ddd9c3901d
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-25.34.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+CARGO_OPTIONAL=1
+CRATES="
+ autocfg@1.1.0
+ cfg-if@1.0.0
+ heck@0.5.0
+ indoc@2.0.4
+ libc@0.2.150
+ memoffset@0.9.0
+ once_cell@1.19.0
+ portable-atomic@1.9.0
+ proc-macro2@1.0.89
+ pyo3-build-config@0.22.6
+ pyo3-ffi@0.22.6
+ pyo3-macros-backend@0.22.6
+ pyo3-macros@0.22.6
+ pyo3@0.22.6
+ quote@1.0.37
+ syn@2.0.87
+ target-lexicon@0.12.16
+ unicode-ident@1.0.12
+ unindent@0.2.3
+"
+
+inherit cargo distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+SRC_URI+="
+ native-extensions? (
+ ${CARGO_CRATE_URIS}
+ )
+"
+
+LICENSE="MIT"
+LICENSE+=" native-extensions? ("
+# Dependent crate licenses
+LICENSE+=" Apache-2.0-with-LLVM-exceptions MIT Unicode-DFS-2016"
+LICENSE+=" )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+native-extensions"
+
+BDEPEND="
+ native-extensions? (
+ ${RUST_DEPEND}
+ dev-util/maturin[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/sqlglotrs/sqlglotrs.*.so"
+
+pkg_setup() {
+ use native-extensions && rust_pkg_setup
+}
+
+src_unpack() {
+ cargo_src_unpack
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use native-extensions; then
+ local DISTUTILS_USE_PEP517=maturin
+ cd sqlglotrs || die
+ distutils-r1_python_compile
+ cd - >/dev/null || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # timing, sigh
+ # https://github.com/tobymao/sqlglot/issues/3961
+ tests/test_generator.py::TestGenerator::test_generate_nested_binary
+ )
+ local EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+ )
+
+ # make sure not to use an earlier installed version
+ local -x SQLGLOTRS_TOKENIZER=$(usex native-extensions 1 0)
+ rm -rf sqlglotrs || die
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}