summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-20 21:59:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-20 22:38:17 +0100
commitf6457c322f8d6c8bd0af12e5041b6ae2c9c68e0d (patch)
tree8735f61f5a7cb84fea8a818a5f0e7a5af5ee65c5 /dev-python
parentdev-python/setuptools: Bump to 66.1.1 (diff)
downloadgentoo-f6457c322f8d6c8bd0af12e5041b6ae2c9c68e0d.tar.gz
gentoo-f6457c322f8d6c8bd0af12e5041b6ae2c9c68e0d.tar.bz2
gentoo-f6457c322f8d6c8bd0af12e5041b6ae2c9c68e0d.zip
dev-python/ensurepip-setuptools: Bump to 66.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
index 442c09cd74f9..4b3f9bd1dfe8 100644
--- a/dev-python/ensurepip-setuptools/Manifest
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -1,2 +1,3 @@
DIST setuptools-65.6.3-py3-none-any.whl 1233963 BLAKE2B 2bad02cc00293c9b6615cdcee9f2da4d66f83c494904c0467054ec15cb5650a7b72caaa52bb8925aea84eb6becd52107ba10763c2b241216d91072a1319f5d24 SHA512 6a9bf2230840ab90b228b433552e8813a176a9ad5f6dc74b20da412fe96c4a7f1df6095aac8dc2f25bd2393aae731927875eb9e7bc05203907539fb4a3b5c8fb
DIST setuptools-66.0.0-py3-none-any.whl 1259316 BLAKE2B ef08be5897d35d63d5b4bea2fb7401c59b1be8ff09a2cc410a97074402228e41bf573820712d76f955fb4a117036bbfd6adc7ff78e33406f5f1a5ebb745eb0a3 SHA512 76efcc28173443d5a000cd0d1ff33e24a423786c32be824cc11cbf137ef755f41416317e326edb56f90aca157ebf49a42e20f8f2445feb7a043c36d4aa537bb4
+DIST setuptools-66.1.1-py3-none-any.whl 1260206 BLAKE2B e5edfb4f26347601b73d01630029cb763a0ea34e76451393fdefd84d970588713ece61b9fdcbfc56709c3d0c48880406fe77e0bdddaa8122352b5f94e850212f SHA512 a2c2852680e3d39660d71dd607449d79ba7ee73bb3d60ccd5f36c84094fc2f8fc946265ec78769537320a06d249ef4089a403a4a7929e3c062b4522f271ccf8f
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild
new file mode 100644
index 000000000000..22682736bd2f
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-66.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}