summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-10-14 18:30:50 +0300
committerSam James <sam@gentoo.org>2022-11-02 05:09:45 +0000
commitc2b15ca2f28c0decd82dff7167b73a455ac1c7b1 (patch)
tree12faa77e4e5a7d7972c14606fab54d457d2ea6a8 /dev-qt/qt5compat
parentqt6-build.eclass: add qt6-build_src_install (diff)
downloadgentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.gz
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.tar.bz2
gentoo-c2b15ca2f28c0decd82dff7167b73a455ac1c7b1.zip
dev-qt/*: add version 6.4.0
Bug: https://bugs.gentoo.org/838970 Bug: https://bugs.gentoo.org/863224 Bug: https://bugs.gentoo.org/875956 Closes: https://bugs.gentoo.org/862525 Closes: https://bugs.gentoo.org/863395 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/27812 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt/qt5compat')
-rw-r--r--dev-qt/qt5compat/Manifest1
-rw-r--r--dev-qt/qt5compat/qt5compat-6.4.0.ebuild18
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-qt/qt5compat/Manifest b/dev-qt/qt5compat/Manifest
index 1b89d952013d..5c7caa627000 100644
--- a/dev-qt/qt5compat/Manifest
+++ b/dev-qt/qt5compat/Manifest
@@ -1 +1,2 @@
DIST qt5compat-everywhere-src-6.3.2.tar.xz 8194996 BLAKE2B cd874a41dc667f8d8e970c962c8475d41139081c8587249204779800bb7e50cf6f33e024cc43a9ab67ff5ae37536ca01e1365c2bca449ae53586b8d410d9b8cc SHA512 12407b27871a3972e3400d9832e454ea221fd18f6c5ce19be8084d085c148d70097b5de8fcedf2a53777b38ce9511f215e56dc145a618e472ceb2caf584c689e
+DIST qt5compat-everywhere-src-6.4.0.tar.xz 14641720 BLAKE2B abed031d736e2f05856a02e96251bf77c12823866c722247360a19d592a71e52a2fb5bac121baa91dd264806fff6b2230d41ab92346ee92c4fcef7607838d4a0 SHA512 d14ebf4ed6061b7154fdd67ac71849bcfb109c9911dcc9279c01bf07b6f58cf26a882f16be6228040e6465345259a16be2296481c2129c88710fa7b4da747ba5
diff --git a/dev-qt/qt5compat/qt5compat-6.4.0.ebuild b/dev-qt/qt5compat/qt5compat-6.4.0.ebuild
new file mode 100644
index 000000000000..2bf0684e946d
--- /dev/null
+++ b/dev-qt/qt5compat/qt5compat-6.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module containing the unsupported Qt 5 APIs"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui,network]
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"