summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-09 02:04:06 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-09 02:21:13 -0400
commitcbc6a0dbded5ae317157f574f2ba40dc2bf5159b (patch)
tree38c485e93f2b856047200a3e47728fff9de88b7e /dev-qt/qtremoteobjects
parentdev-qt/qtquicktimeline: drop 6.7.9999 (diff)
downloadgentoo-cbc6a0dbded5ae317157f574f2ba40dc2bf5159b.tar.gz
gentoo-cbc6a0dbded5ae317157f574f2ba40dc2bf5159b.tar.bz2
gentoo-cbc6a0dbded5ae317157f574f2ba40dc2bf5159b.zip
dev-qt/qtremoteobjects: drop 6.7.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtremoteobjects')
-rw-r--r--dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild b/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild
deleted file mode 100644
index 49b703f47ebd..000000000000
--- a/dev-qt/qtremoteobjects/qtremoteobjects-6.7.9999.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Inter-Process Communication (IPC) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-IUSE="qml"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- qml? (
- ~dev-qt/qtbase-${PV}:6[gui]
- ~dev-qt/qtdeclarative-${PV}:6
- )
-"
-DEPEND="
- ${RDEPEND}
- test? ( ~dev-qt/qtbase-${PV}:6[gui] )
-"
-
-src_configure() {
- # same issue as bug #913692 when tests are enabled
- has_version "=dev-qt/qtdeclarative-$(ver_cut 1-3)*:6" &&
- local mycmakeargs=( $(cmake_use_find_package qml Qt6Qml) )
-
- qt6-build_src_configure
-}
-
-src_test() {
- # tests re-use 127.0.0.1:65213 and randomly fail if ran at same time
- qt6-build_src_test -j1
-}
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- # installs 30+ test binaries like "qt6/bin/state" and, given
- # otherwise empty, "can" delete the directory rather than list
- rm -r -- "${D}${QT6_BINDIR}" || die
- fi
-}