summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-09 05:15:34 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-10 06:24:44 -0500
commit930c2dbfeee49f7a1210af8f619a3ab64df723b9 (patch)
tree042945fd4e5248a53a59b55c4baa758258dc45d2 /dev-qt/qttools
parentsys-devel/llvm-common: Remove old (diff)
downloadgentoo-930c2dbfeee49f7a1210af8f619a3ab64df723b9.tar.gz
gentoo-930c2dbfeee49f7a1210af8f619a3ab64df723b9.tar.bz2
gentoo-930c2dbfeee49f7a1210af8f619a3ab64df723b9.zip
dev-qt/qttools: migrate live to llvm-r1, allow slot 18
Tested with 18.1.0_rc2 at same time, seems to be fine so may as well do this now. Skip .cmake.conf comment in 6.6.9999 given the minimum was introduced in 6.7+. Unsure how often Qt intend to bump this, odds are we may not need to pay attention to it if we clean old versions up faster. Not changing 6.6.1 given 6.6.2 is close and it can be updated at same time to spare rebuilds. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/qttools-6.6.9999.ebuild19
-rw-r--r--dev-qt/qttools/qttools-6.7.9999.ebuild19
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild19
3 files changed, 29 insertions, 28 deletions
diff --git a/dev-qt/qttools/qttools-6.6.9999.ebuild b/dev-qt/qttools/qttools-6.6.9999.ebuild
index 9f6085643a94..49dfe820f8ac 100644
--- a/dev-qt/qttools/qttools-6.6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.6.9999.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit desktop llvm optfeature qt6-build
+LLVM_COMPAT=( {15..18} )
+LLVM_OPTIONAL=1
+inherit desktop llvm-r1 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -20,6 +22,7 @@ IUSE="
# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
REQUIRED_USE="
assistant? ( widgets )
+ clang? ( ${LLVM_REQUIRED_USE} )
designer? ( qml widgets )
distancefieldgenerator? ( qml widgets )
pixeltool? ( widgets )
@@ -31,11 +34,15 @@ REQUIRED_USE="
# and 3rdparty/ tries to FetchContent gtest)
RESTRICT="test"
-LLVM_MAX_SLOT=17
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,widgets?]
assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? ( <sys-devel/clang-$((LLVM_MAX_SLOT+1)):= )
+ clang? (
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ sys-devel/llvm:${LLVM_SLOT}
+ ')
+ )
designer? (
~dev-qt/qtbase-${PV}:6[xml,zstd=]
zstd? ( app-arch/zstd:= )
@@ -52,12 +59,8 @@ DEPEND="
)
"
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
pkg_setup() {
- use clang && llvm_pkg_setup
+ use clang && llvm-r1_pkg_setup
}
src_configure() {
diff --git a/dev-qt/qttools/qttools-6.7.9999.ebuild b/dev-qt/qttools/qttools-6.7.9999.ebuild
index 2a9817bfe028..99231843045d 100644
--- a/dev-qt/qttools/qttools-6.7.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.7.9999.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit desktop llvm optfeature qt6-build
+LLVM_COMPAT=( {15..18} ) # see .cmake.conf for minimum
+LLVM_OPTIONAL=1
+inherit desktop llvm-r1 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -20,6 +22,7 @@ IUSE="
# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
REQUIRED_USE="
assistant? ( widgets )
+ clang? ( ${LLVM_REQUIRED_USE} )
designer? ( qml widgets )
distancefieldgenerator? ( qml widgets )
pixeltool? ( widgets )
@@ -31,14 +34,14 @@ REQUIRED_USE="
# and 3rdparty/ tries to FetchContent gtest)
RESTRICT="test"
-QTTOOLS_LLVM_SLOTS=({17..15}) # QDOC_MINIMUM_CLANG_VERSION
-LLVM_MAX_SLOT=${QTTOOLS_LLVM_SLOTS[0]}
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,widgets?]
assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
clang? (
- <sys-devel/clang-$((LLVM_MAX_SLOT+1)):=
- || ( $(printf "sys-devel/clang:%d " "${QTTOOLS_LLVM_SLOTS[@]}") )
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ sys-devel/llvm:${LLVM_SLOT}
+ ')
)
designer? (
~dev-qt/qtbase-${PV}:6[xml,zstd=]
@@ -56,12 +59,8 @@ DEPEND="
)
"
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
pkg_setup() {
- use clang && llvm_pkg_setup
+ use clang && llvm-r1_pkg_setup
}
src_configure() {
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index 2a9817bfe028..99231843045d 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -3,7 +3,9 @@
EAPI=8
-inherit desktop llvm optfeature qt6-build
+LLVM_COMPAT=( {15..18} ) # see .cmake.conf for minimum
+LLVM_OPTIONAL=1
+inherit desktop llvm-r1 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -20,6 +22,7 @@ IUSE="
# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
REQUIRED_USE="
assistant? ( widgets )
+ clang? ( ${LLVM_REQUIRED_USE} )
designer? ( qml widgets )
distancefieldgenerator? ( qml widgets )
pixeltool? ( widgets )
@@ -31,14 +34,14 @@ REQUIRED_USE="
# and 3rdparty/ tries to FetchContent gtest)
RESTRICT="test"
-QTTOOLS_LLVM_SLOTS=({17..15}) # QDOC_MINIMUM_CLANG_VERSION
-LLVM_MAX_SLOT=${QTTOOLS_LLVM_SLOTS[0]}
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,widgets?]
assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
clang? (
- <sys-devel/clang-$((LLVM_MAX_SLOT+1)):=
- || ( $(printf "sys-devel/clang:%d " "${QTTOOLS_LLVM_SLOTS[@]}") )
+ $(llvm_gen_dep '
+ sys-devel/clang:${LLVM_SLOT}
+ sys-devel/llvm:${LLVM_SLOT}
+ ')
)
designer? (
~dev-qt/qtbase-${PV}:6[xml,zstd=]
@@ -56,12 +59,8 @@ DEPEND="
)
"
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}"
-}
-
pkg_setup() {
- use clang && llvm_pkg_setup
+ use clang && llvm-r1_pkg_setup
}
src_configure() {