summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-09 02:04:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-09 02:21:15 -0400
commit7b43838924776504f8e5080e8ebe8a9600186810 (patch)
treece7c65518a989b128b19ee61185502a82c71a81c /dev-qt/qtvirtualkeyboard
parentdev-qt/qttranslations: drop 6.7.9999 (diff)
downloadgentoo-7b43838924776504f8e5080e8ebe8a9600186810.tar.gz
gentoo-7b43838924776504f8e5080e8ebe8a9600186810.tar.bz2
gentoo-7b43838924776504f8e5080e8ebe8a9600186810.zip
dev-qt/qtvirtualkeyboard: drop 6.7.9999
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtvirtualkeyboard')
-rw-r--r--dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild b/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
deleted file mode 100644
index 4639b2cf069d..000000000000
--- a/dev-qt/qtvirtualkeyboard/qtvirtualkeyboard-6.7.9999.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2023-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Customizable input framework and virtual keyboard for Qt"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
-fi
-
-IUSE="+spell"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[gui]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtsvg-${PV}:6
- spell? ( app-text/hunspell:= )
-"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(qt_feature spell hunspell)
- -DINPUT_vkb_handwriting=no # neither cerence nor myscript are packaged
- )
-
- qt6-build_src_configure
-}
-
-src_test() {
- local CMAKE_SKIP_TESTS=(
- # rarely randomly(?) fails even with -j1
- tst_layoutfilesystem
- )
-
- if use spell && has_version app-dicts/myspell-en; then
- # 99% pass but minor sub-tests fail with myspell-en, needs looking into
- ewarn "Warning: notable tests were skipped due to ${_} being installed"
- CMAKE_SKIP_TESTS+=(
- tst_inputpanel
- tst_inputpanelcontrols2
- )
- else
- einfo "tst_inputpanel can take >5mins, not known to actually hang"
- fi
-
- qt6-build_src_test
-}