summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-23 15:46:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:04 -0400
commitb1cbadc14748cfda478a574bf9b6dc0ef341f979 (patch)
treeea466ac273e0f0eb53da9945eb7f9a0982af2d64 /dev-qt/qtwebengine
parentdev-qt/qtbase: various adjustments to run tests (diff)
downloadgentoo-b1cbadc14748cfda478a574bf9b6dc0ef341f979.tar.gz
gentoo-b1cbadc14748cfda478a574bf9b6dc0ef341f979.tar.bz2
gentoo-b1cbadc14748cfda478a574bf9b6dc0ef341f979.zip
dev-qt/qtwebengine: make pkgcheck happier (qt6)
ebuild needs more real refactoring (will do in a separate revbump), but at least address pkgcheck's warnings in this one wrt src_unpack (which triggers indirect git-r3 usage), not quite sure what the debug check was doing (repeated) there, and (currently) no patchset to unpack so can just drop the whole thing. For patchsets this may be better handled in qt6-build given it is the one inheriting git-r3. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild26
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild26
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.9999.ebuild26
3 files changed, 18 insertions, 60 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
index 512c148fc7e0..0a8cb920e4cd 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
@@ -5,7 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
-inherit check-reqs estack flag-o-matic multiprocessing python-any-r1 qt6-build
+inherit check-reqs estack flag-o-matic multiprocessing
+inherit python-any-r1 qt6-build toolchain-funcs
CHROMIUM_VER=108.0.5359.181
CHROMIUM_PATCHES_VER=114.0.5735.133
@@ -151,24 +152,6 @@ pkg_preinst() {
elog "tldr: Your web browsing experience will be compromised."
}
-src_unpack() {
- # bug 307861
- eshopts_push -s extglob
- if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn
- ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
- ewarn
- fi
- eshopts_pop
-
- case ${QT6_BUILD_TYPE} in
- live) git-r3_src_unpack ;&
- release) default ;;
- esac
-}
-
src_prepare() {
# bug 620444 - ensure local headers are used
find . -type f -name "*.pr[fio]" -exec \
@@ -184,7 +167,10 @@ src_prepare() {
local file
while read file; do
echo "#error This file should not be used!" > "${file}" || die
- done < <(find src/3rdparty/chromium/third_party/icu -type f "(" -name "*.c" -o -name "*.cpp" -o -name "*.h" ")" 2>/dev/null)
+ done < <(
+ find src/3rdparty/chromium/third_party/icu -type f \
+ \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) 2>/dev/null
+ )
fi
qt6-build_src_prepare
diff --git a/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
index 3a82bdc90577..b174b5b618f7 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
@@ -5,7 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
-inherit check-reqs estack flag-o-matic multiprocessing python-any-r1 qt6-build
+inherit check-reqs estack flag-o-matic multiprocessing
+inherit python-any-r1 qt6-build toolchain-funcs
CHROMIUM_VER=108.0.5359.181
CHROMIUM_PATCHES_VER=113.0.5672.126
@@ -147,24 +148,6 @@ pkg_preinst() {
elog "tldr: Your web browsing experience will be compromised."
}
-src_unpack() {
- # bug 307861
- eshopts_push -s extglob
- if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn
- ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
- ewarn
- fi
- eshopts_pop
-
- case ${QT6_BUILD_TYPE} in
- live) git-r3_src_unpack ;&
- release) default ;;
- esac
-}
-
src_prepare() {
# bug 620444 - ensure local headers are used
find . -type f -name "*.pr[fio]" -exec \
@@ -180,7 +163,10 @@ src_prepare() {
local file
while read file; do
echo "#error This file should not be used!" > "${file}" || die
- done < <(find src/3rdparty/chromium/third_party/icu -type f "(" -name "*.c" -o -name "*.cpp" -o -name "*.h" ")" 2>/dev/null)
+ done < <(
+ find src/3rdparty/chromium/third_party/icu -type f \
+ \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) 2>/dev/null
+ )
fi
qt6-build_src_prepare
diff --git a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
index 31ce642b8e27..aa10febb98d1 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
@@ -5,7 +5,8 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
PYTHON_REQ_USE="xml(+)"
-inherit check-reqs estack flag-o-matic multiprocessing python-any-r1 qt6-build
+inherit check-reqs estack flag-o-matic multiprocessing
+inherit python-any-r1 qt6-build toolchain-funcs
CHROMIUM_VER=108.0.5359.181
CHROMIUM_PATCHES_VER=114.0.5735.133
@@ -147,24 +148,6 @@ pkg_preinst() {
elog "tldr: Your web browsing experience will be compromised."
}
-src_unpack() {
- # bug 307861
- eshopts_push -s extglob
- if is-flagq '-g?(gdb)?([1-9])'; then
- ewarn
- ewarn "You have enabled debug info (probably have -g or -ggdb in your CFLAGS/CXXFLAGS)."
- ewarn "You may experience really long compilation times and/or increased memory usage."
- ewarn "If compilation fails, please try removing -g/-ggdb before reporting a bug."
- ewarn
- fi
- eshopts_pop
-
- case ${QT6_BUILD_TYPE} in
- live) git-r3_src_unpack ;&
- release) default ;;
- esac
-}
-
src_prepare() {
# bug 620444 - ensure local headers are used
find . -type f -name "*.pr[fio]" -exec \
@@ -180,7 +163,10 @@ src_prepare() {
local file
while read file; do
echo "#error This file should not be used!" > "${file}" || die
- done < <(find src/3rdparty/chromium/third_party/icu -type f "(" -name "*.c" -o -name "*.cpp" -o -name "*.h" ")" 2>/dev/null)
+ done < <(
+ find src/3rdparty/chromium/third_party/icu -type f \
+ \( -name '*.c' -o -name '*.cpp' -o -name '*.h' \) 2>/dev/null
+ )
fi
qt6-build_src_prepare