summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-23 21:36:04 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:04 -0400
commitd9c475c6914828843ef8e21068144e7bd1b8fc92 (patch)
treef4f65eadb26611d276e3b2031ac8ae1e84a4ffa1 /dev-qt/qtwebengine
parentwww-client/qutebrowser: remove widevine workaround for prefix (diff)
downloadgentoo-d9c475c6914828843ef8e21068144e7bd1b8fc92.tar.gz
gentoo-d9c475c6914828843ef8e21068144e7bd1b8fc92.tar.bz2
gentoo-d9c475c6914828843ef8e21068144e7bd1b8fc92.zip
dev-qt/qtwebengine: do not install gn (qt6)
qtwebengine handling of gn does not allow to use CBUILD toolchain, and only when cross-compiling it will look for system's. Also does not respect *FLAGS as upstream intentially commented these out because someone did a bug report with overzealous flags (QTBUG-64759). And, unfortunately, qtwebengine's is modified and so dev-util/gn may not work as expected with it (plus will need CMakeLists modifications to be found). Bare that, two possible options would be: 1. dev-qt/qtwebengine-gn or so to BDEPEND on and build cleanly 2. fix the mess that is the modified gen.py, and use BUILD_ variables For now at least skip installing it as it'll just cause conflicts if we want to do this later and is not really useful unless want to do something like BDEPEND="cross? ( dev-qt/qtwebengine )". Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtwebengine')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild3
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild3
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.9999.ebuild3
3 files changed, 9 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
index a25052c49759..d1552563301d 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.5.2.ebuild
@@ -232,6 +232,9 @@ src_configure() {
-DQT_FEATURE_webengine_webrtc=on
-DQT_FEATURE_webengine_webrtc_pipewire=$(usex screencast on off)
#-DQT_FEATURE_xcb=off
+
+ # TODO: fix gn cross build or split + depend on dev-qt/qtwebengine-gn
+ -DINSTALL_GN=off
)
qt6-build_src_configure
diff --git a/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
index 11142144bf67..1028503b6bdc 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.5.9999.ebuild
@@ -228,6 +228,9 @@ src_configure() {
-DQT_FEATURE_webengine_webrtc=on
-DQT_FEATURE_webengine_webrtc_pipewire=$(usex screencast on off)
#-DQT_FEATURE_xcb=off
+
+ # TODO: fix gn cross build or split + depend on dev-qt/qtwebengine-gn
+ -DINSTALL_GN=off
)
qt6-build_src_configure
diff --git a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
index 2b2b85752645..77a4ac3d9fff 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
@@ -228,6 +228,9 @@ src_configure() {
-DQT_FEATURE_webengine_webrtc=on
-DQT_FEATURE_webengine_webrtc_pipewire=$(usex screencast on off)
#-DQT_FEATURE_xcb=off
+
+ # TODO: fix gn cross build or split + depend on dev-qt/qtwebengine-gn
+ -DINSTALL_GN=off
)
qt6-build_src_configure