summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-21 13:30:21 +0100
committerSam James <sam@gentoo.org>2024-10-21 13:30:36 +0100
commite5a20b4a5f5ea23af5d64c7455344e69b90b9dfc (patch)
tree329c60230ad011ed7e6773956adcc24f9db135ce /dev-qt
parentsys-devel/gcc: switch to upstream variant of libstdc++ vs clang patch for 15 (diff)
downloadgentoo-e5a20b4a5f5ea23af5d64c7455344e69b90b9dfc.tar.gz
gentoo-e5a20b4a5f5ea23af5d64c7455344e69b90b9dfc.tar.bz2
gentoo-e5a20b4a5f5ea23af5d64c7455344e69b90b9dfc.zip
dev-qt/qtwebengine: add cstdints for GCC 15
Closes: https://bugs.gentoo.org/938685 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.14_p20240510-gcc15-cstdint.patch30
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.14_p20240510.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.14_p20240510-gcc15-cstdint.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.14_p20240510-gcc15-cstdint.patch
new file mode 100644
index 000000000000..0adc39e400ab
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.15.14_p20240510-gcc15-cstdint.patch
@@ -0,0 +1,30 @@
+--- a/src/3rdparty/chromium/third_party/webrtc/api/task_queue/task_queue_base.h
++++ b/src/3rdparty/chromium/third_party/webrtc/api/task_queue/task_queue_base.h
+@@ -10,6 +10,7 @@
+ #ifndef API_TASK_QUEUE_TASK_QUEUE_BASE_H_
+ #define API_TASK_QUEUE_TASK_QUEUE_BASE_H_
+
++#include <cstdint>
+ #include <memory>
+
+ #include "api/task_queue/queued_task.h"
+--- a/src/3rdparty/chromium/third_party/perfetto/src/trace_processor/importers/gzip/gzip_utils.h
++++ b/src/3rdparty/chromium/third_party/perfetto/src/trace_processor/importers/gzip/gzip_utils.h
+@@ -17,6 +17,7 @@
+ #ifndef SRC_TRACE_PROCESSOR_IMPORTERS_GZIP_GZIP_UTILS_H_
+ #define SRC_TRACE_PROCESSOR_IMPORTERS_GZIP_GZIP_UTILS_H_
+
++#include <cstdint>
+ #include <memory>
+
+ struct z_stream_s;
+--- a/src/3rdparty/chromium/third_party/perfetto/include/perfetto/ext/tracing/core/slice.h
++++ b/src/3rdparty/chromium/third_party/perfetto/include/perfetto/ext/tracing/core/slice.h
+@@ -20,6 +20,7 @@
+ #include <stddef.h>
+ #include <string.h>
+
++#include <cstdint>
+ #include <memory>
+ #include <string>
+ #include <vector> \ No newline at end of file
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.14_p20240510.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.14_p20240510.ebuild
index 31ca92a14959..2b65624ad585 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.14_p20240510.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.14_p20240510.ebuild
@@ -102,6 +102,7 @@ PATCHES=(
"${WORKDIR}/${PATCHSET}"
"${FILESDIR}/${PN}-5.15.13_p20240510-gcc15.patch"
"${FILESDIR}/${P}-re2.patch"
+ "${FILESDIR}/${PN}-5.15.14_p20240510-gcc15-cstdint.patch"
)
python_check_deps() {