summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-01-08 09:51:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-01-08 09:54:33 +0100
commitf3ca79a36c5f332c5fd1df468f7aaf23350d45ee (patch)
tree533edc5841de6cb86b55f8a127618e559754da60 /dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
parentdev-ros/ivcon: bump to 0.1.7 (diff)
downloadgentoo-f3ca79a36c5f332c5fd1df468f7aaf23350d45ee.tar.gz
gentoo-f3ca79a36c5f332c5fd1df468f7aaf23350d45ee.tar.bz2
gentoo-f3ca79a36c5f332c5fd1df468f7aaf23350d45ee.zip
dev-ros/dynamic_reconfigure: bump to 1.6.0
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild')
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
new file mode 100644
index 000000000000..a6bb2ae12003
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"