summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:29:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:50 +0200
commitbf1082c1a9a2ab4483b2ff28ff9586d4e5297005 (patch)
tree06f25ed1d66c38c8cdb123f0f06ada16ebf45cd5 /dev-ros/qt_dotgraph
parentdev-ros/rqt_publisher: convert to python-single-r1 (diff)
downloadgentoo-bf1082c1a9a2ab4483b2ff28ff9586d4e5297005.tar.gz
gentoo-bf1082c1a9a2ab4483b2ff28ff9586d4e5297005.tar.bz2
gentoo-bf1082c1a9a2ab4483b2ff28ff9586d4e5297005.zip
dev-ros/qt_dotgraph: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/qt_dotgraph')
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-0.4.1.ebuild8
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-0.4.1.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-0.4.1.ebuild
index ae0790b08408..5dd8cebe50df 100644
--- a/dev-ros/qt_dotgraph/qt_dotgraph-0.4.1.ebuild
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-0.4.1.ebuild
@@ -15,11 +15,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/pydot[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pydot[\${PYTHON_USEDEP}]")
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/pygraphviz[\${PYTHON_USEDEP}]")
)"
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
index ae0790b08408..5dd8cebe50df 100644
--- a/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-9999.ebuild
@@ -15,11 +15,11 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-python/pydot[${PYTHON_USEDEP}]
- >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pydot[\${PYTHON_USEDEP}]")
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pygraphviz[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/pygraphviz[\${PYTHON_USEDEP}]")
)"