summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-12-21 16:20:06 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-12-21 16:51:27 +0100
commitb3d237138ab9ef68155431247f14bafc0f238983 (patch)
tree8afe39c3ec2a24ca28aac3a33eb01f6ee3a5f441 /dev-ros/robot_localization/files
parentdev-ros/rosbag_storage: add missing tinyxml2 dep (diff)
downloadgentoo-b3d237138ab9ef68155431247f14bafc0f238983.tar.gz
gentoo-b3d237138ab9ef68155431247f14bafc0f238983.tar.bz2
gentoo-b3d237138ab9ef68155431247f14bafc0f238983.zip
dev-ros/robot_localization: bump to 2.6.2
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/robot_localization/files')
-rw-r--r--dev-ros/robot_localization/files/nowerror.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/robot_localization/files/nowerror.patch b/dev-ros/robot_localization/files/nowerror.patch
new file mode 100644
index 000000000000..936ad259bc6f
--- /dev/null
+++ b/dev-ros/robot_localization/files/nowerror.patch
@@ -0,0 +1,13 @@
+Index: robot_localization-2.6.2/CMakeLists.txt
+===================================================================
+--- robot_localization-2.6.2.orig/CMakeLists.txt
++++ robot_localization-2.6.2/CMakeLists.txt
+@@ -36,7 +36,7 @@ if(NOT EIGEN3_FOUND)
+ set(EIGEN_PACKAGE Eigen)
+ endif()
+
+-set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall;-Werror")
++set_directory_properties(PROPERTIES COMPILE_OPTIONS "-std=c++14;-Wall")
+ add_definitions(-DEIGEN_NO_DEBUG -DEIGEN_MPL2_ONLY)
+
+ set(ROSLINT_CPP_OPTS "--filter=-build/c++11,-runtime/references")