summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-03 13:05:08 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-03 13:21:51 +0200
commit977feb80dc52114fa8294fe812918f307ef6d075 (patch)
tree92cc7e4c92cf6452ff201470a92c0e94e3a50c15 /dev-ros/rospy/rospy-1.14.2.ebuild
parentdev-ros/roscpp: Bump to 1.14.2. (diff)
downloadgentoo-977feb80dc52114fa8294fe812918f307ef6d075.tar.gz
gentoo-977feb80dc52114fa8294fe812918f307ef6d075.tar.bz2
gentoo-977feb80dc52114fa8294fe812918f307ef6d075.zip
dev-ros/rospy: Bump to 1.14.2.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-ros/rospy/rospy-1.14.2.ebuild')
-rw-r--r--dev-ros/rospy/rospy-1.14.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rospy/rospy-1.14.2.ebuild b/dev-ros/rospy/rospy-1.14.2.ebuild
new file mode 100644
index 000000000000..6491d58ff8b1
--- /dev/null
+++ b/dev-ros/rospy/rospy-1.14.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roscpp[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ # Other tests need these nodes
+ exeinto /usr/share/${PN}
+ doexe test_nodes/*
+}