summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-11-28 12:42:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-11-28 14:28:46 +0100
commit189842040b20c5f6974a6d060458b101dce60393 (patch)
treee12f2fc6e66bfe56410b8dd47a8bd3be7b52e265 /dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild
parentdev-ros/rosserial_windows: Bump to 0.7.5. (diff)
downloadgentoo-189842040b20c5f6974a6d060458b101dce60393.tar.gz
gentoo-189842040b20c5f6974a6d060458b101dce60393.tar.bz2
gentoo-189842040b20c5f6974a6d060458b101dce60393.zip
dev-ros/rosserial_xbee: Bump to 0.7.5.
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild
new file mode 100644
index 000000000000..ec22fe2a5621
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-0.7.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"