summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:28:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:52 +0200
commit0eb41f9db417fac539eb815fda9cc364f528555b (patch)
treec528d64f5ea538a3477c0cd61351380e133ed8ef /dev-ros/roswtf/roswtf-1.15.8.ebuild
parentdev-ros/xmlrpcpp: Bump to 1.15.8. (diff)
downloadgentoo-0eb41f9db417fac539eb815fda9cc364f528555b.tar.gz
gentoo-0eb41f9db417fac539eb815fda9cc364f528555b.tar.bz2
gentoo-0eb41f9db417fac539eb815fda9cc364f528555b.zip
dev-ros/roswtf: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/roswtf/roswtf-1.15.8.ebuild')
-rw-r--r--dev-ros/roswtf/roswtf-1.15.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/roswtf/roswtf-1.15.8.ebuild b/dev-ros/roswtf/roswtf-1.15.8.ebuild
new file mode 100644
index 000000000000..c9baf4196f78
--- /dev/null
+++ b/dev-ros/roswtf/roswtf-1.15.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool for diagnosing issues with a running ROS system"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/paramiko[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-util/rosdep[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-util/rosinstall[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"