summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:19:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:13 +0100
commitc17adb5acbdba208d8e4acba7947db05a922a5b6 (patch)
tree76b61ebdf582711c51265df523f2bee59047f5d2 /dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild
parentdev-ros/rqt_nav_view: Bump to 0.5.6. (diff)
downloadgentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.tar.gz
gentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.tar.bz2
gentoo-c17adb5acbdba208d8e4acba7947db05a922a5b6.zip
dev-ros/rqt_pose_view: Bump to 0.5.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild')
-rw-r--r--dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild
new file mode 100644
index 000000000000..983f8746bc4e
--- /dev/null
+++ b/dev-ros/rqt_pose_view/rqt_pose_view-0.5.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing 3D poses"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-python/PyQt4[opengl,${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"