summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:19:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:14 +0100
commit29d5e665b8683bfc450c53dc1780bdcf1c8e5254 (patch)
treefb5453d92dfd2322bab99546a7762afe2fb61a4b /dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild
parentdev-ros/rqt_robot_steering: Bump to 0.5.6. (diff)
downloadgentoo-29d5e665b8683bfc450c53dc1780bdcf1c8e5254.tar.gz
gentoo-29d5e665b8683bfc450c53dc1780bdcf1c8e5254.tar.bz2
gentoo-29d5e665b8683bfc450c53dc1780bdcf1c8e5254.zip
dev-ros/rqt_runtime_monitor: Bump to 0.5.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild')
-rw-r--r--dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild
new file mode 100644
index 000000000000..a97e538591f9
--- /dev/null
+++ b/dev-ros/rqt_runtime_monitor/rqt_runtime_monitor-0.5.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin viewing DiagnosticsArray messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"