summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-12 12:48:32 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-12 13:30:58 +0100
commite9fdfb8844307aeb14aca682665a3c96d45a7fb1 (patch)
treeeeaf6a0d2904c618246b369ca388c1d6f33ccca8 /dev-ros/rviz/rviz-9999.ebuild
parentdev-python/markups: Remove dead impls (diff)
downloadgentoo-e9fdfb8844307aeb14aca682665a3c96d45a7fb1.tar.gz
gentoo-e9fdfb8844307aeb14aca682665a3c96d45a7fb1.tar.bz2
gentoo-e9fdfb8844307aeb14aca682665a3c96d45a7fb1.zip
dev-ros/rviz: bump to 1.13.6.
Also run tests under virtx. They still fail though. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rviz/rviz-9999.ebuild')
-rw-r--r--dev-ros/rviz/rviz-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ros/rviz/rviz-9999.ebuild b/dev-ros/rviz/rviz-9999.ebuild
index 46cc11490699..358973db8678 100644
--- a/dev-ros/rviz/rviz-9999.ebuild
+++ b/dev-ros/rviz/rviz-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -7,7 +7,7 @@ ROS_REPO_URI="https://github.com/ros-visualization/rviz"
KEYWORDS="~amd64"
PYTHON_COMPAT=( python2_7 )
-inherit ros-catkin
+inherit ros-catkin virtualx
DESCRIPTION="3D visualization tool for ROS"
LICENSE="BSD"
@@ -66,3 +66,7 @@ src_configure() {
local mycatkincmakeargs=( "-DUseQt5=ON" )
ros-catkin_src_configure
}
+
+src_test() {
+ virtx ros-catkin_src_test
+}