summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 16:32:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:31 +0200
commitd4867dfab9f0ca84ec9a16423d7b8cb9856e44e7 (patch)
tree2226a19eaef18c0b69a5969c01b4fa4d2a684f1f /dev-ros/test_rospy/test_rospy-1.11.14.ebuild
parentdev-ros/test_rosparam: Initial import. Ebuild by me. (diff)
downloadgentoo-d4867dfab9f0ca84ec9a16423d7b8cb9856e44e7.tar.gz
gentoo-d4867dfab9f0ca84ec9a16423d7b8cb9856e44e7.tar.bz2
gentoo-d4867dfab9f0ca84ec9a16423d7b8cb9856e44e7.zip
dev-ros/test_rospy: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/test_rospy/test_rospy-1.11.14.ebuild')
-rw-r--r--dev-ros/test_rospy/test_rospy-1.11.14.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_rospy/test_rospy-1.11.14.ebuild b/dev-ros/test_rospy/test_rospy-1.11.14.ebuild
new file mode 100644
index 000000000000..174ea68dbec0
--- /dev/null
+++ b/dev-ros/test_rospy/test_rospy-1.11.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/test_rosmaster"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rospy"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/test_rosmaster[${PYTHON_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosbuild
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"