summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-25 07:45:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-25 08:40:05 +0200
commit02dfd03c96ce05917109bc75ecc0259b506e8cbc (patch)
tree343aab20b172f9c054928d95d67e2c3af0b2d5ff /dev-ros
parentdev-ros/rqt_msg: remove old (diff)
downloadgentoo-02dfd03c96ce05917109bc75ecc0259b506e8cbc.tar.gz
gentoo-02dfd03c96ce05917109bc75ecc0259b506e8cbc.tar.bz2
gentoo-02dfd03c96ce05917109bc75ecc0259b506e8cbc.zip
dev-ros/rqt_msg: bump to 0.4.8 and update to split repos
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/rqt_msg/Manifest1
-rw-r--r--dev-ros/rqt_msg/metadata.xml2
-rw-r--r--dev-ros/rqt_msg/rqt_msg-0.4.8.ebuild28
-rw-r--r--dev-ros/rqt_msg/rqt_msg-9999.ebuild5
4 files changed, 32 insertions, 4 deletions
diff --git a/dev-ros/rqt_msg/Manifest b/dev-ros/rqt_msg/Manifest
index 7bb8c4d74093..394fd92f7b08 100644
--- a/dev-ros/rqt_msg/Manifest
+++ b/dev-ros/rqt_msg/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_msg-0.4.8.tar.gz 6806 SHA256 0f5a928077b9844b7aa558a80c9cc9171c5091868e58f6d0c02a1936c5d74757 SHA512 d1598315f8cccdc83059046d0bbbd5fe970e4a2981f08cc9e3841fae12b85ca3f907a1509b024809ebf3834f8a2e40b7ed26ce39b2e1638d120ea5a749dd715e WHIRLPOOL 3d211b17363f52615db3fbced2790bfdaad365f0e98dd33a2a2d1f4708905bf130d21965330a5d4a5fe0eba95d93a70d33000ad8054b4461a499bb26b5202b15
diff --git a/dev-ros/rqt_msg/metadata.xml b/dev-ros/rqt_msg/metadata.xml
index cb473d142b8e..09730bd0b8e4 100644
--- a/dev-ros/rqt_msg/metadata.xml
+++ b/dev-ros/rqt_msg/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo ROS Project</name>
</maintainer>
<upstream>
- <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+ <remote-id type="github">ros-visualization/rqt_msg</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-ros/rqt_msg/rqt_msg-0.4.8.ebuild b/dev-ros/rqt_msg/rqt_msg-0.4.8.ebuild
new file mode 100644
index 000000000000..01361aa919a8
--- /dev/null
+++ b/dev-ros/rqt_msg/rqt_msg-0.4.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_msg"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin for introspecting available ROS message types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_console[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_msg/rqt_msg-9999.ebuild b/dev-ros/rqt_msg/rqt_msg-9999.ebuild
index 09f1b98f227f..01361aa919a8 100644
--- a/dev-ros/rqt_msg/rqt_msg-9999.ebuild
+++ b/dev-ros/rqt_msg/rqt_msg-9999.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_msg"
PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
inherit ros-catkin